summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-04 09:29:11 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-04 09:44:34 +0100
commitc4feefc232f243086a45ed3ad850b46091fdd61c (patch)
treedda535ad987484089172033e7256c6acf847b6af /dev-python
parentnet-libs/miniupnpc: Prevent installing .gz manpage (diff)
downloadgentoo-c4feefc232f243086a45ed3ad850b46091fdd61c.tar.gz
gentoo-c4feefc232f243086a45ed3ad850b46091fdd61c.tar.bz2
gentoo-c4feefc232f243086a45ed3ad850b46091fdd61c.zip
dev-python/miniupnpc: Bump to 2.0.20180203
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/miniupnpc/Manifest1
-rw-r--r--dev-python/miniupnpc/miniupnpc-2.0.20180203.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/miniupnpc/Manifest b/dev-python/miniupnpc/Manifest
index b271b2ddd982..de2f1c56dda9 100644
--- a/dev-python/miniupnpc/Manifest
+++ b/dev-python/miniupnpc/Manifest
@@ -1,2 +1,3 @@
DIST miniupnpc-2.0.20170509.tar.gz 86055 BLAKE2B 7da640c4baac58aa26965a670877953b4c2d27aff08b604366bad6913b30c152d52120099f37c6250eeed97396ff412a4dd6000179070a82eebd3c052596b0d0 SHA512 71ec052ef6c8ad0d529e467ddae6eae19a93b9816174eeac753aa90e036cc2f00cf7e8d1cdb188ef8280849a988fe2995e37b63f8e2a361e021c1d1b306bff6f
DIST miniupnpc-2.0.20171212.tar.gz 86607 BLAKE2B fce582c4125192f74f6ffb174295020af1c9b574b2094f5565a5e49641820a2d9cef719de59cb94bfd207182505237c22cf58425e1a7b47f5dfe2eb84c07d3c5 SHA512 d25708f4e2ef7311878ba6d17cb506f4bfe5c9cc6b7a79e4168f143ca9da8b96beb018c42dd735f0b23806668eba2308b7de26d1b506d91c23f79c7ed77399a0
+DIST miniupnpc-2.0.20180203.tar.gz 86772 BLAKE2B 6959d7033f12d3cbe52bbe1ec2178c068a448441d22501f44a7228b2050b53ff5e955d390ff03071e6f34df2a652040bf5ab23c59aca16dc4379e380dd46fea8 SHA512 b8ebf02ed01c5217a789397b7c224ba21d233cb544ccdfd907fb9c6f49adae6864eb17963b9b9f654ecf3fde864c191fd7d00c5cf614771a7137a030f341f226
diff --git a/dev-python/miniupnpc/miniupnpc-2.0.20180203.ebuild b/dev-python/miniupnpc/miniupnpc-2.0.20180203.ebuild
new file mode 100644
index 000000000000..dd70b6c5a34d
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-2.0.20180203.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for UPnP client library"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/miniupnpc-${PV}:0="
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/miniupnpc-2.0.20171102-shared-lib.patch
+)
+
+# DOCS are installed by net-libs/miniupnpc.
+DOCS=()
+
+# Example test command:
+# python -c 'import miniupnpc; u = miniupnpc.UPnP(); u.discover(); u.selectigd(); print(u.externalipaddress())'