summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 19:15:29 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 19:35:00 +0200
commitc6ef36b4b6618727a3d62eb8d11d043f0c4b7543 (patch)
tree0335a57f1c7b8054b3b1de713cf5bceef10f846f /dev-python
parentnet-misc/openssh: add libressl support (diff)
downloadgentoo-c6ef36b4b6618727a3d62eb8d11d043f0c4b7543.tar.gz
gentoo-c6ef36b4b6618727a3d62eb8d11d043f0c4b7543.tar.bz2
gentoo-c6ef36b4b6618727a3d62eb8d11d043f0c4b7543.zip
dev-python/cryptography: add libressl support
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/cryptography-1.0.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/cryptography/cryptography-1.0.1-r1.ebuild b/dev-python/cryptography/cryptography-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..65f533d0140c
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# only works with >=pypy-2.6
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}