summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-19 22:24:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:01 -0400
commit5f7ab1d0350672c2d9f6c90793c32e57aaec34b6 (patch)
tree4177f8da5240c9c8a2757b9851a76a08fce0fe36 /dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
parentdev-qt/*: import qt6 live ebuilds from ::qt (diff)
downloadgentoo-5f7ab1d0350672c2d9f6c90793c32e57aaec34b6.tar.gz
gentoo-5f7ab1d0350672c2d9f6c90793c32e57aaec34b6.tar.bz2
gentoo-5f7ab1d0350672c2d9f6c90793c32e57aaec34b6.zip
dev-qt/*: streamline style a bit across qt6 ebuilds
Misc minor adjustments / sorting, but more commonly: * use same RDEPEND + DEPEND ordering everywhere, bit of both order is used all across and sometime inverted in Qt5's so let's match skel.ebuild to avoid confusion * use explicit :6 slots, not necessary with =PV but this is more about normalizing usage when multiple slots exist (plus *cough* qa-vdb won't complaint anymore) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtimageformats/qtimageformats-6.9999.ebuild')
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild b/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
index ffa831e51aa5..90f3f24d0d6f 100644
--- a/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
+++ b/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,13 +13,13 @@ fi
IUSE="mng"
-DEPEND="
- =dev-qt/qtbase-${PV}*[gui]
+RDEPEND="
+ =dev-qt/qtbase-${PV}*:6[gui]
media-libs/libwebp:=
media-libs/tiff:=
mng? ( media-libs/libmng:= )
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(