summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-02 01:25:19 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-02 02:22:45 -0500
commitd32f3d415b24e86f44723b348cd3de9b598adb4b (patch)
treebe11da3f560ee1d4a108c286a2914f1d2ad5fef0 /dev-qt/qtscxml
parentdev-qt/qtremoteobjects: add 6.8.1 (diff)
downloadgentoo-d32f3d415b24e86f44723b348cd3de9b598adb4b.tar.gz
gentoo-d32f3d415b24e86f44723b348cd3de9b598adb4b.tar.bz2
gentoo-d32f3d415b24e86f44723b348cd3de9b598adb4b.zip
dev-qt/qtscxml: add 6.8.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 44c5a91cdbf5..cdb226157f91 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -3,3 +3,4 @@ DIST qtscxml-everywhere-opensource-src-5.15.16.tar.xz 429268 BLAKE2B 3d3b41eab16
DIST qtscxml-everywhere-src-6.7.2.tar.xz 1168452 BLAKE2B 7cb06fd09758aaea28ccada62aa51b427c265416afa3f152601cadd1c9586050e87d36f8cf9679ca3ef83777bfec1119d861bd9491a176460d58beb5376e4ce4 SHA512 4eba366c2c10593cfc0fdeeff92aa9951b838837cacf113bf849b5da68da4d41d550490bc4be28620f766ab412ca4066c71ee7a1ff18651dd08267b01df6c2fe
DIST qtscxml-everywhere-src-6.7.3.tar.xz 1168340 BLAKE2B 3082ed9be66233a53ec99a684c87c9211b8805f9dd6967f9e0b7b509d0fb809704d39e0c688e039103cc36f4ad0f4aef39823b3b57e16b67126c9772b5fd7754 SHA512 d2d561f7a94d1fad2ad578b602c51c5f506bb0ea2c145647ea490399bac5995191c56ad62454775f15a2d3973e99cd220487ead3d5873163949b9ddd58bdada7
DIST qtscxml-everywhere-src-6.8.0.tar.xz 557512 BLAKE2B 9d56aae62dee54155a9cae87dc855d27308409680faccf470af8f56cee84f29c26348d7db260c3b5dbef617e6adde75baf50aa3c9360b6cf2a5a44ed33b14126 SHA512 8b045845c1cbb35e1c3c998b940e47b4c69d3cf17256805a1964f51675c6166db472c6a26f081519cbcf0f2ded78315580ffd2637b6c249f5bc7c6aa000f6c1b
+DIST qtscxml-everywhere-src-6.8.1.tar.xz 558424 BLAKE2B 7b0c27288678844d85676f0c8e4126b268f8b94ed229fd1e86282cfe26b4d700c7d89cacaefb17f91c4caec28a32cb4deb002ac129831c85fd3175387a7d5b88 SHA512 294d830569f05450a57fd30741707f7c6d42d07ad9ae03840e41c1382f72f8d3408d9cc1ba16145ede51f5ca510cef87b0ca298991c7697a7c2b58b0db8f8f29
diff --git a/dev-qt/qtscxml/qtscxml-6.8.1.ebuild b/dev-qt/qtscxml/qtscxml-6.8.1.ebuild
new file mode 100644
index 000000000000..0f087eb496fc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}