summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:16:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:44:57 +0100
commitdc23cce8f1dd1831bd4735285bfa9efe3e591638 (patch)
tree57f24af2b048adb830229f41a5e7299d5d098536 /dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild
parentdev-qt/qtwaylandscanner: 5.15.8 version bump (diff)
downloadgentoo-dc23cce8f1dd1831bd4735285bfa9efe3e591638.tar.gz
gentoo-dc23cce8f1dd1831bd4735285bfa9efe3e591638.tar.bz2
gentoo-dc23cce8f1dd1831bd4735285bfa9efe3e591638.zip
dev-qt/qtwebchannel: 5.15.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild')
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild
new file mode 100644
index 000000000000..e357da75e2aa
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-5.15.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick src/src.pro
+ qt_use_disable_mod qml qml src/webchannel/webchannel.pro
+
+ qt5-build_src_prepare
+}