summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-22 18:46:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-22 18:52:04 -0400
commitd6bad4026d30c5cd1de2b5f3e91c60fef2842330 (patch)
tree31000cf2a7fee910298e53455c6226fb97d3d3a4 /dev-qt
parentnet-im/discord: add 0.0.61, drop 0.0.60 (diff)
downloadgentoo-d6bad4026d30c5cd1de2b5f3e91c60fef2842330.tar.gz
gentoo-d6bad4026d30c5cd1de2b5f3e91c60fef2842330.tar.bz2
gentoo-d6bad4026d30c5cd1de2b5f3e91c60fef2842330.zip
dev-qt/qtbase: skip flaky tst_qprocess
Closes: https://bugs.gentoo.org/936484 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtbase/qtbase-6.7.2-r1.ebuild3
-rw-r--r--dev-qt/qtbase/qtbase-6.7.9999.ebuild3
-rw-r--r--dev-qt/qtbase/qtbase-6.8.9999.ebuild3
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild3
4 files changed, 4 insertions, 8 deletions
diff --git a/dev-qt/qtbase/qtbase-6.7.2-r1.ebuild b/dev-qt/qtbase/qtbase-6.7.2-r1.ebuild
index 428654198862..54a41ae62c97 100644
--- a/dev-qt/qtbase/qtbase-6.7.2-r1.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.2-r1.ebuild
@@ -275,6 +275,7 @@ src_test() {
# randomly fails without -j1, and not worth it over this (bug #916181)
tst_qfiledialog{,2}
# may randomly hang+timeout, perhaps related to -j as well
+ tst_qprocess #936484
tst_qtimer
# these can be flaky depending on the environment/toolchain
tst_qlogging # backtrace log test can easily vary
@@ -309,7 +310,6 @@ src_test() {
tst_qicoimageformat
tst_qimagereader
tst_qimage
- tst_qprocess
')
# fails due to hppa's NaN handling, needs looking into (bug #914371)
$(usev hppa '
@@ -319,7 +319,6 @@ src_test() {
# bug #914033
$(usev sparc '
tst_qbuffer
- tst_qprocess
tst_qtconcurrentiteratekernel
')
# note: for linux, upstream only really runs+maintains tests for amd64
diff --git a/dev-qt/qtbase/qtbase-6.7.9999.ebuild b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
index 435584eeecbe..21ce4da21682 100644
--- a/dev-qt/qtbase/qtbase-6.7.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
@@ -274,6 +274,7 @@ src_test() {
# randomly fails without -j1, and not worth it over this (bug #916181)
tst_qfiledialog{,2}
# may randomly hang+timeout, perhaps related to -j as well
+ tst_qprocess #936484
tst_qtimer
# these can be flaky depending on the environment/toolchain
tst_qlogging # backtrace log test can easily vary
@@ -308,7 +309,6 @@ src_test() {
tst_qicoimageformat
tst_qimagereader
tst_qimage
- tst_qprocess
')
# fails due to hppa's NaN handling, needs looking into (bug #914371)
$(usev hppa '
@@ -318,7 +318,6 @@ src_test() {
# bug #914033
$(usev sparc '
tst_qbuffer
- tst_qprocess
tst_qtconcurrentiteratekernel
')
# note: for linux, upstream only really runs+maintains tests for amd64
diff --git a/dev-qt/qtbase/qtbase-6.8.9999.ebuild b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
index 04fb1a0aaefe..a07ea4a4d232 100644
--- a/dev-qt/qtbase/qtbase-6.8.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
@@ -286,6 +286,7 @@ src_test() {
# randomly fails without -j1, and not worth it over this (bug #916181)
tst_qfiledialog{,2}
# may randomly hang+timeout, perhaps related to -j as well
+ tst_qprocess #936484
tst_qtimer
# these can be flaky depending on the environment/toolchain
tst_qlogging # backtrace log test can easily vary
@@ -320,7 +321,6 @@ src_test() {
tst_qicoimageformat
tst_qimagereader
tst_qimage
- tst_qprocess
')
# fails due to hppa's NaN handling, needs looking into (bug #914371)
$(usev hppa '
@@ -330,7 +330,6 @@ src_test() {
# bug #914033
$(usev sparc '
tst_qbuffer
- tst_qprocess
tst_qtconcurrentiteratekernel
')
# note: for linux, upstream only really runs+maintains tests for amd64
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 04fb1a0aaefe..a07ea4a4d232 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -286,6 +286,7 @@ src_test() {
# randomly fails without -j1, and not worth it over this (bug #916181)
tst_qfiledialog{,2}
# may randomly hang+timeout, perhaps related to -j as well
+ tst_qprocess #936484
tst_qtimer
# these can be flaky depending on the environment/toolchain
tst_qlogging # backtrace log test can easily vary
@@ -320,7 +321,6 @@ src_test() {
tst_qicoimageformat
tst_qimagereader
tst_qimage
- tst_qprocess
')
# fails due to hppa's NaN handling, needs looking into (bug #914371)
$(usev hppa '
@@ -330,7 +330,6 @@ src_test() {
# bug #914033
$(usev sparc '
tst_qbuffer
- tst_qprocess
tst_qtconcurrentiteratekernel
')
# note: for linux, upstream only really runs+maintains tests for amd64