summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-18 16:39:57 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-18 16:59:36 +0100
commit5aad6bba18bd5414b81714ba5e292332b8ec2588 (patch)
tree219173d33b43595c06ba8dd139942c14ef506fd2 /dev-ros/audio_play/audio_play-0.2.11.ebuild
parentdev-ros/audio_common_msgs: Bump to 0.2.11. (diff)
downloadgentoo-5aad6bba18bd5414b81714ba5e292332b8ec2588.tar.gz
gentoo-5aad6bba18bd5414b81714ba5e292332b8ec2588.tar.bz2
gentoo-5aad6bba18bd5414b81714ba5e292332b8ec2588.zip
dev-ros/audio_play: Bump to 0.2.11.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/audio_play/audio_play-0.2.11.ebuild')
-rw-r--r--dev-ros/audio_play/audio_play-0.2.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/audio_play/audio_play-0.2.11.ebuild b/dev-ros/audio_play/audio_play-0.2.11.ebuild
new file mode 100644
index 000000000000..d8c67040ec3b
--- /dev/null
+++ b/dev-ros/audio_play/audio_play-0.2.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Outputs audio to a speaker from a source node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:0.10
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-plugins/gst-plugins-alsa:0.10
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"