summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 09:48:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:05 +0200
commit19504bf9645a01c17f0aa23fa256c0360b68af24 (patch)
treef77b644987a815dd44f09a0392c980af4816b47e /dev-ros/calibration_estimation
parentdev-ros/ament_cmake_version: bump to 1.1.4 (diff)
downloadgentoo-19504bf9645a01c17f0aa23fa256c0360b68af24.tar.gz
gentoo-19504bf9645a01c17f0aa23fa256c0360b68af24.tar.bz2
gentoo-19504bf9645a01c17f0aa23fa256c0360b68af24.zip
dev-ros/calibration_estimation: Bump to 0.10.15.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/calibration_estimation')
-rw-r--r--dev-ros/calibration_estimation/Manifest1
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/Manifest b/dev-ros/calibration_estimation/Manifest
index 0c2018f9b46d..7d01d5458acf 100644
--- a/dev-ros/calibration_estimation/Manifest
+++ b/dev-ros/calibration_estimation/Manifest
@@ -1 +1,2 @@
DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+DIST calibration-0.10.15.tar.gz 115940 BLAKE2B 43c8564ad8f15894d04571fbb3c6bc2059a5d232de3fb6225b715b078a11fef2e19283e3f0587ed47f2d52784ade22bebdf4680f6b30c585da2fbbfa1c45b0a5 SHA512 06ffc9ae6872b914eb6954996d165e2aa65d786756896a21be1ab3b5c20f1df3340e2fdf9804bc3cd78089f5b2e05eaed2a4376e70e98ccaaa8a88d95c3f4894
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
new file mode 100644
index 000000000000..266d2c3caf21
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/matplotlib[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/scipy[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/urdf_parser_py[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/py3.patch" )
+
+src_prepare() {
+ ros-catkin_src_prepare
+ sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
+ 2to3 -w src/*/*.py src/*/*/*.py test/*.py || die
+}
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}