summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:27:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:15 +0100
commit0e913188bdbc6dcc82f60f9dc92d7bd6d00845b7 (patch)
tree8966e2b28ba65b06d13bb71c429af1de655d5c98 /dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild
parentdev-ros/costmap_2d: Remove old (diff)
downloadgentoo-0e913188bdbc6dcc82f60f9dc92d7bd6d00845b7.tar.gz
gentoo-0e913188bdbc6dcc82f60f9dc92d7bd6d00845b7.tar.bz2
gentoo-0e913188bdbc6dcc82f60f9dc92d7bd6d00845b7.zip
dev-ros/costmap_2d: add missing := dep on tinyxml2
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild')
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild b/dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..82162901a3db
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.15.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl:=
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"