summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:58:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:58:22 +0200
commitfb8418a627a03b9e03feccb47f6637a269260977 (patch)
tree989d812bfc64430364cca78243d080576430c016 /dev-ros/depth_image_proc/depth_image_proc-9999.ebuild
parentdev-ros/camera_calibration: Initial import. Ebuild by me. (diff)
downloadgentoo-fb8418a627a03b9e03feccb47f6637a269260977.tar.gz
gentoo-fb8418a627a03b9e03feccb47f6637a269260977.tar.bz2
gentoo-fb8418a627a03b9e03feccb47f6637a269260977.zip
dev-ros/depth_image_proc: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/depth_image_proc/depth_image_proc-9999.ebuild')
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild b/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild
new file mode 100644
index 000000000000..47d48da9bd6d
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}"