summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-25 15:32:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-25 15:48:45 +0200
commita10828acaf595c0bd0f67d01a8ef0577ab747f29 (patch)
tree3c373c6d9b22753aa73d0da12833de6b65a49c9c /dev-ros/move_base/move_base-1.15.2.ebuild
parentdev-ros/map_server: Bump to 1.15.2. (diff)
downloadgentoo-a10828acaf595c0bd0f67d01a8ef0577ab747f29.tar.gz
gentoo-a10828acaf595c0bd0f67d01a8ef0577ab747f29.tar.bz2
gentoo-a10828acaf595c0bd0f67d01a8ef0577ab747f29.zip
dev-ros/move_base: Bump to 1.15.2.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/move_base/move_base-1.15.2.ebuild')
-rw-r--r--dev-ros/move_base/move_base-1.15.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/move_base/move_base-1.15.2.ebuild b/dev-ros/move_base/move_base-1.15.2.ebuild
new file mode 100644
index 000000000000..2905e24c89be
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.15.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"