summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-26 11:31:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-26 11:31:24 +0200
commitc5ae78171b3a50cf516ba756fd5fdf96638265b1 (patch)
tree6422ac857fd8559a6dd81739ba979483637f4006 /dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild
parentdev-ros/robot_state_publisher: remove old (diff)
downloadgentoo-c5ae78171b3a50cf516ba756fd5fdf96638265b1.tar.gz
gentoo-c5ae78171b3a50cf516ba756fd5fdf96638265b1.tar.bz2
gentoo-c5ae78171b3a50cf516ba756fd5fdf96638265b1.zip
dev-ros/robot_state_publisher: bump to 1.13.1
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild')
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild
new file mode 100644
index 000000000000..f6dd74f278d8
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"