summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:30:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:56 +0200
commit6dfa0e1d1fcb12bfd9037fd8f3315630b05cf948 (patch)
tree00aa248577e71545c9eb79d9c73baa90b48fa478 /dev-ros/rostopic/rostopic-1.15.8.ebuild
parentdev-ros/rostest: Bump to 1.15.8. (diff)
downloadgentoo-6dfa0e1d1fcb12bfd9037fd8f3315630b05cf948.tar.gz
gentoo-6dfa0e1d1fcb12bfd9037fd8f3315630b05cf948.tar.bz2
gentoo-6dfa0e1d1fcb12bfd9037fd8f3315630b05cf948.zip
dev-ros/rostopic: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.15.8.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.15.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.15.8.ebuild b/dev-ros/rostopic/rostopic-1.15.8.ebuild
new file mode 100644
index 000000000000..6482c6da1be0
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.15.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"