summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:39:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:05 +0200
commit8d403f54648b67e9f2ed86cb324228336de2385d (patch)
treef780f87480ff9058c623c2f7d1f9a3b6e169b16a /dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild
parentdev-ros/rqt_graph: remove old (diff)
downloadgentoo-8d403f54648b67e9f2ed86cb324228336de2385d.tar.gz
gentoo-8d403f54648b67e9f2ed86cb324228336de2385d.tar.bz2
gentoo-8d403f54648b67e9f2ed86cb324228336de2385d.zip
dev-ros/rqt_graph: bump to 0.4.8 and update to split repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild
new file mode 100644
index 000000000000..1f2bff4c39fc
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"