summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:05:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:43 +0200
commitac53b3032e9c769acd9efdc345c6c03384d343f3 (patch)
tree05348b8da5ccf7d43887e58826e324a6790cfaa4 /dev-ros/rqt_plot
parentdev-ros/rqt_pose_view: Remove old (diff)
downloadgentoo-ac53b3032e9c769acd9efdc345c6c03384d343f3.tar.gz
gentoo-ac53b3032e9c769acd9efdc345c6c03384d343f3.tar.bz2
gentoo-ac53b3032e9c769acd9efdc345c6c03384d343f3.zip
dev-ros/rqt_plot: bump to 0.4.12
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_plot')
-rw-r--r--dev-ros/rqt_plot/Manifest1
-rw-r--r--dev-ros/rqt_plot/rqt_plot-0.4.12.ebuild31
-rw-r--r--dev-ros/rqt_plot/rqt_plot-9999.ebuild5
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-ros/rqt_plot/Manifest b/dev-ros/rqt_plot/Manifest
index ae08339c8502..13abc5f751c7 100644
--- a/dev-ros/rqt_plot/Manifest
+++ b/dev-ros/rqt_plot/Manifest
@@ -1 +1,2 @@
+DIST rqt_plot-0.4.12.tar.gz 19862 BLAKE2B b98e9d3c5862674997e6e6792332beae945a798eadb8ca0fd5b9d105fa04e6fe9a36033d48535d1918b5f3ab6d40cc5c3e0babae7e55079f013f4acd998dbdbc SHA512 adb20495b1c7402fda5685afe300d25ea7117fbe540025588c0fc30bf5791f408286a8ba9101dafd97d88a11e5561cd0f1b8c35e868bf979b6c5833b3c9f85e6
DIST rqt_plot-0.4.8.tar.gz 19153 BLAKE2B 300ab2d7b27dddcad1403bd10aae46406b95aa00f80ac55bd479241deeef746720db5f03dc62957500774ddaa97379902441363c8e590d34c032a25f8d6ebbf9 SHA512 c06a5c0990ee071c20f278c44456404b9f9b7e211b16aa5d670ccffcbf6cd69f24d2c30e930c99c97b4288b996138a73243f877656dcfcf960c4684df3deaf5d
diff --git a/dev-ros/rqt_plot/rqt_plot-0.4.12.ebuild b/dev-ros/rqt_plot/rqt_plot-0.4.12.ebuild
new file mode 100644
index 000000000000..2e279799993c
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-0.4.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_plot"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyqtgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_plot/rqt_plot-9999.ebuild b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
index 845689ab2731..2e279799993c 100644
--- a/dev-ros/rqt_plot/rqt_plot-9999.ebuild
+++ b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_plot"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin