summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-13 11:11:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-13 11:13:05 +0200
commit24786c56e38216134f4a986bd399cb60b5abd898 (patch)
treee3f7669cf1aa416cd6a65053726fd2657045f1f7 /dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild
parentdev-ros/rqt_robot_monitor: bump to 0.5.13 (diff)
downloadgentoo-24786c56e38216134f4a986bd399cb60b5abd898.tar.gz
gentoo-24786c56e38216134f4a986bd399cb60b5abd898.tar.bz2
gentoo-24786c56e38216134f4a986bd399cb60b5abd898.zip
dev-ros/rqt_tf_tree: bump to 0.6.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild')
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild
new file mode 100644
index 000000000000..29eb0bd0e67a
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_tf_tree"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/qt_dotgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]") )"
+PATCHES=( "${FILESDIR}/yaml.patch" )