summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 14:02:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commitec0cc1809a19095e5dd7c25884b7f67310761f3a (patch)
treef769c7684535425c68a10b49819a7311fb6704c9 /dev-ros/turtle_tf2/turtle_tf2-9999.ebuild
parentdev-ros/turtle_tf: use proper usedep on messages. (diff)
downloadgentoo-ec0cc1809a19095e5dd7c25884b7f67310761f3a.tar.gz
gentoo-ec0cc1809a19095e5dd7c25884b7f67310761f3a.tar.bz2
gentoo-ec0cc1809a19095e5dd7c25884b7f67310761f3a.zip
dev-ros/turtle_tf2: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/turtle_tf2/turtle_tf2-9999.ebuild')
-rw-r--r--dev-ros/turtle_tf2/turtle_tf2-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/turtle_tf2/turtle_tf2-9999.ebuild b/dev-ros/turtle_tf2/turtle_tf2-9999.ebuild
new file mode 100644
index 000000000000..64d8a70429e6
--- /dev/null
+++ b/dev-ros/turtle_tf2/turtle_tf2-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write a tf2 broadcaster and listener with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/turtlesim[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"