summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-21 19:55:51 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-21 19:58:56 +0100
commit8af3d970a89135f2d94c7f694ecc46da60fc3f27 (patch)
treeaf4642f7ff0e83f2ae73d16f9152f9699164f863 /dev-ruby/activerecord/activerecord-4.2.8.ebuild
parentdev-ruby/actionmailer: add rails 4.2.8 (diff)
downloadgentoo-8af3d970a89135f2d94c7f694ecc46da60fc3f27.tar.gz
gentoo-8af3d970a89135f2d94c7f694ecc46da60fc3f27.tar.bz2
gentoo-8af3d970a89135f2d94c7f694ecc46da60fc3f27.zip
dev-ruby/activerecord: add rails 4.2.8
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/activerecord/activerecord-4.2.8.ebuild')
-rw-r--r--dev-ruby/activerecord/activerecord-4.2.8.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/activerecord/activerecord-4.2.8.ebuild b/dev-ruby/activerecord/activerecord-4.2.8.ebuild
new file mode 100644
index 000000000000..fc3f9c8b85d8
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-4.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~amd64-linux"
+IUSE="mysql postgres sqlite"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-6.0:6.0
+ sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
+ mysql? ( || ( dev-ruby/mysql2:0.4 >=dev-ruby/mysql2-0.3.13:0.3 ) )
+ postgres? ( >=dev-ruby/pg-0.15.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/sqlite3-1.3.5
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4:5
+ )"
+
+DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ rm ../Gemfile.lock || die
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Add back json in the Gemfile because we dropped some dependencies
+ # earlier that implicitly required it.
+ sed -i -e '$agem "json"' ../Gemfile || die
+
+ # Avoid test depending on mysql adapter which we don't support for
+ # this Rails version to simplify our dependencies.
+ rm test/cases/connection_specification/resolver_test.rb || die
+
+ # Avoid single test using mysql dependencies.
+ rm test/cases/invalid_connection_test.rb || die
+}
+
+each_ruby_test() {
+ if use sqlite; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+}