summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-25 07:24:01 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-25 07:24:01 +0200
commit679c028afe022db4d009541b5ab38a704bc635be (patch)
tree3e8ecbec6e6d750807c884799787ea7a89ba5285 /dev-ruby/appraisal
parentdev-ruby/sshkey: add 3.0.0 (diff)
downloadgentoo-679c028afe022db4d009541b5ab38a704bc635be.tar.gz
gentoo-679c028afe022db4d009541b5ab38a704bc635be.tar.bz2
gentoo-679c028afe022db4d009541b5ab38a704bc635be.zip
dev-ruby/appraisal: add 2.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/appraisal')
-rw-r--r--dev-ruby/appraisal/Manifest1
-rw-r--r--dev-ruby/appraisal/appraisal-2.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/appraisal/Manifest b/dev-ruby/appraisal/Manifest
index 8bf551c9db24..b58c1a1e02ee 100644
--- a/dev-ruby/appraisal/Manifest
+++ b/dev-ruby/appraisal/Manifest
@@ -1 +1,2 @@
DIST appraisal-2.4.1.gem 26112 BLAKE2B 47a9e91117889c52022446cd052cc0c08891d0932ab88a74f61914dd46c1e1bbe7d2a82a6afacd749b4eaf88516d80676582d9fb593d606b8da2e7888455a739 SHA512 8f2a55e2a8e497c11f6b5f2f25c565b91ed8b8bc67b68263cbfa364a3ffeb501440a7122a09885de70b8e465e38e293aa491aa7c838d58855fed0efc63f2c219
+DIST appraisal-2.5.0.gem 26112 BLAKE2B b72a994167f332f91a94c8afdb611f9cf4ac573e741ed6fb509b8ecd0767422dbff9e61d062cafb8eb527180d0951821c8ddd9e097e391f464e18c905b34d447 SHA512 8ee9a4e60c25635577b00037816c61d10623045607ef051b6508a30b9d1b0885764275a7a688473e29d8dab0af9d188916217df9fb75667139a3acd9ed0db27d
diff --git a/dev-ruby/appraisal/appraisal-2.5.0.ebuild b/dev-ruby/appraisal/appraisal-2.5.0.ebuild
new file mode 100644
index 000000000000..6195e8a8bc3d
--- /dev/null
+++ b/dev-ruby/appraisal/appraisal-2.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for testing your library against different versions of dependencies"
+HOMEPAGE="https://github.com/thoughtbot/appraisal"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/bundler
+ dev-ruby/rake
+ >=dev-ruby/thor-0.14.0
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/activesupport-3.2.21
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/thor/ s:^:#:' Gemfile || die
+
+ # Skip the acceptance tests since they expect to install gems from
+ # the network and do not expect multiple ruby versions to be
+ # present.
+ rm -rf spec/acceptance || die
+ sed -i -e '/built_in/ s:^:#:' spec/appraisal/appraisal_file_spec.rb || die
+}