summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/atomic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/atomic')
-rw-r--r--dev-ruby/atomic/Manifest2
-rw-r--r--dev-ruby/atomic/atomic-1.1.16.ebuild33
-rw-r--r--dev-ruby/atomic/atomic-1.1.99.ebuild34
-rw-r--r--dev-ruby/atomic/metadata.xml8
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-ruby/atomic/Manifest b/dev-ruby/atomic/Manifest
new file mode 100644
index 000000000000..41379eab2b0d
--- /dev/null
+++ b/dev-ruby/atomic/Manifest
@@ -0,0 +1,2 @@
+DIST atomic-1.1.16.gem 16896 SHA256 56748e82ab4a29bb76e4f73843587a322666ed15d90e1925119afaa12b38dfc4 SHA512 d8c3acb5eebbd5a9d22b783860eb036893f03580c70480c3226dbdf22e081aabdd7edb96eb830688e342e42286586c57a29141332ccc0e59d8df2dff7dcd9c70 WHIRLPOOL f179763300d9c0e6d43b5231d6ec6bfb468dec4c937e16d41a6c731b66b4d96b780f9b006016fecbc738e77b9afe430083943e04dd73fc89bc61272316df4f8d
+DIST atomic-1.1.99.gem 17920 SHA256 093fa4d0522bfac61b4793b00c8e14dae846d5c1d28fa9dd6ab6112be1ce09ce SHA512 9c7762f6c32d11b2c5b45be68954ca12c753d2b4683167158a037ce791d72b13d940beef5bf6dd445c8b12e358c62d2a9f43a609fb3b7c7357fea4f66316063c WHIRLPOOL 72970b2f8a503eb29fe2aa2702b8a91f796c5f0382d2ff3f3f809a5eb39db5252e1732bfc919021f77e7a308a0ce05dc4d2cd1c9027412942077dac95804cf0d
diff --git a/dev-ruby/atomic/atomic-1.1.16.ebuild b/dev-ruby/atomic/atomic-1.1.16.ebuild
new file mode 100644
index 000000000000..604a5d0ac91f
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/atomic/atomic-1.1.99.ebuild b/dev-ruby/atomic/atomic-1.1.99.ebuild
new file mode 100644
index 000000000000..0d822d109476
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.99.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/atomic/metadata.xml b/dev-ruby/atomic/metadata.xml
new file mode 100644
index 000000000000..12c94a00c0fd
--- /dev/null
+++ b/dev-ruby/atomic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">headius/ruby-atomic</remote-id>
+ </upstream>
+</pkgmetadata>