summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-27 13:22:11 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-27 13:25:46 +0200
commitf13305d0cc9688130daf0e06f845862678d2378e (patch)
tree3f46a37d930a713d391e0313474a74406b1e3712 /dev-ruby/equalizer
parentdev-ruby/naught: enable ruby32 (diff)
downloadgentoo-f13305d0cc9688130daf0e06f845862678d2378e.tar.gz
gentoo-f13305d0cc9688130daf0e06f845862678d2378e.tar.bz2
gentoo-f13305d0cc9688130daf0e06f845862678d2378e.zip
dev-ruby/equalizer: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/equalizer')
-rw-r--r--dev-ruby/equalizer/equalizer-0.0.11-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/equalizer/equalizer-0.0.11-r2.ebuild b/dev-ruby/equalizer/equalizer-0.0.11-r2.ebuild
new file mode 100644
index 000000000000..bf2f6202e98b
--- /dev/null
+++ b/dev-ruby/equalizer/equalizer-0.0.11-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to define equality, equivalence and inspection methods"
+HOMEPAGE="https://github.com/dkubb/equalizer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/devtools/d" spec/spec_helper.rb || die
+
+ # Avoid a failing spec caused by memoizable 0.4.2, and we ignore it
+ # there as well.
+ rm spec/unit/equalizer/included_spec.rb || die
+}