summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-07 06:19:44 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-07 06:19:44 +0100
commit52bb57449ffc3f5f033ee8711f1180efc2f18c69 (patch)
tree9d989b343d77e9965bb6416d1412a78b51da1ef6 /dev-ruby/ffi/ffi-1.9.18.ebuild
parentnet-im/skypeforlinux: New version (5.0.0.5), remove old (diff)
downloadgentoo-52bb57449ffc3f5f033ee8711f1180efc2f18c69.tar.gz
gentoo-52bb57449ffc3f5f033ee8711f1180efc2f18c69.tar.bz2
gentoo-52bb57449ffc3f5f033ee8711f1180efc2f18c69.zip
dev-ruby/ffi: add 1.9.18
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ffi/ffi-1.9.18.ebuild')
-rw-r--r--dev-ruby/ffi/ffi-1.9.18.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/ffi/ffi-1.9.18.ebuild b/dev-ruby/ffi/ffi-1.9.18.ebuild
new file mode 100644
index 000000000000..1bfb8ddd8d61
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.9.18.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="https://wiki.github.com/ffi/ffi"
+
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND+=" virtual/libffi"
+DEPEND+=" virtual/libffi"
+
+all_ruby_prepare() {
+ sed -i -e '/tasks/ s:^:#:' \
+ -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die
+
+ # Fix Makefile for tests
+ sed -i -e '/CCACHE :=/ s:^:#:' \
+ -e 's/-O2//' \
+ -e 's/^CFLAGS =/CFLAGS +=/' libtest/GNUmakefile || die
+
+ # Remove bundled version of libffi.
+ rm -rf ext/ffi_c/libffi || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ffi_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ffi_c V=1
+ cp ext/ffi_c/ffi_c$(get_modname) lib/ || die
+
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+each_ruby_test() {
+ CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}