summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-06-27 07:48:05 +0200
committerHans de Graaff <graaff@gentoo.org>2021-06-27 07:50:19 +0200
commitcb3bac8ecec2ad5b4468445561d71364b3fc720d (patch)
tree65cacb64f1ab755d1020249f00cc64fcf8e83a99 /dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
parentdev-ruby/mocha: add 1.13.0 (diff)
downloadgentoo-cb3bac8ecec2ad5b4468445561d71364b3fc720d.tar.gz
gentoo-cb3bac8ecec2ad5b4468445561d71364b3fc720d.tar.bz2
gentoo-cb3bac8ecec2ad5b4468445561d71364b3fc720d.zip
dev-ruby/instance_storage: add 2.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/instance_storage/instance_storage-2.0.0.ebuild')
-rw-r--r--dev-ruby/instance_storage/instance_storage-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild b/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
new file mode 100644
index 000000000000..3050aecf5278
--- /dev/null
+++ b/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Manage class instances with dictionary"
+HOMEPAGE="https://rubygems.org/gems/instance_storage/"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/instance_storage_test.rb || die
+}