summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/loofah
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/loofah')
-rw-r--r--dev-ruby/loofah/Manifest2
-rw-r--r--dev-ruby/loofah/loofah-2.0.1.ebuild28
-rw-r--r--dev-ruby/loofah/loofah-2.0.2.ebuild28
-rw-r--r--dev-ruby/loofah/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/loofah/Manifest b/dev-ruby/loofah/Manifest
new file mode 100644
index 000000000000..685dbca896f7
--- /dev/null
+++ b/dev-ruby/loofah/Manifest
@@ -0,0 +1,2 @@
+DIST loofah-2.0.1.gem 59392 SHA256 e47f811395f87885374e780e64034a7263b52d5308352e32851ccd0c1bd7c66c SHA512 6bed99fced69538aa64c6ef67878420ef88d427c7cf6e74599f33ff9cfc9fcd6e9450de30a922d54bdead4851a39ec0b4bd58e58ab5ed1ef89610151c7f9270f WHIRLPOOL d100ba311a54303a11227cc50d82c4469f2d66462b8614e3a1ff9d512340981219431968282dd84c4cad0970c4b462a0f6ce0bfa792f34bc3f83ab4cc2789807
+DIST loofah-2.0.2.gem 59392 SHA256 1ab5fb9a1dca7b955e75d582f57d236de46430ab5c5b5a33987c04d3ec93ccc7 SHA512 f61b853847bd0dfecada1d8eb4f0ab1b179c804f0ac7c74f927a8275f6d1e9fb35456abdaa0ca3f81d8281f31c77088757fe2f994332ce0a742bb89fb1d2986c WHIRLPOOL a6ba55875d168e9a8c5bd3ad99e50f124f598ce21159025516ae7b4a7cf80e4a587f7c5f34c01ef568e4796a4a006ec4135b2da3938d40bbab7ce852a5ee54c4
diff --git a/dev-ruby/loofah/loofah-2.0.1.ebuild b/dev-ruby/loofah/loofah-2.0.1.ebuild
new file mode 100644
index 000000000000..abc8449c72a6
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A general library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
+
+all_ruby_prepare() {
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
diff --git a/dev-ruby/loofah/loofah-2.0.2.ebuild b/dev-ruby/loofah/loofah-2.0.2.ebuild
new file mode 100644
index 000000000000..abc8449c72a6
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A general library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
+
+all_ruby_prepare() {
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
diff --git a/dev-ruby/loofah/metadata.xml b/dev-ruby/loofah/metadata.xml
new file mode 100644
index 000000000000..a80394fe7ba9
--- /dev/null
+++ b/dev-ruby/loofah/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">flavorjones/loofah</remote-id>
+ </upstream>
+</pkgmetadata>