summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 07:37:40 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-23 07:37:40 +0100
commit418aa66dbc4a46c18579e5b88e880771ca37e7b2 (patch)
tree3151ab3b030e46631808606365a2a27d1d21456b /dev-ruby/ntlm-http
parentdev-ruby/thread_safe: all arches stable (diff)
downloadgentoo-418aa66dbc4a46c18579e5b88e880771ca37e7b2.tar.gz
gentoo-418aa66dbc4a46c18579e5b88e880771ca37e7b2.tar.bz2
gentoo-418aa66dbc4a46c18579e5b88e880771ca37e7b2.zip
dev-ruby/ntlm-http: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ntlm-http')
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..960bd91a5093
--- /dev/null
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_DOC_SOURCES="lib README"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby/NTLM HTTP provides NTLM authentication over http"
+HOMEPAGE="http://www.mindflowsolutions.net/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+all_ruby_prepare() {
+ find . -name '*.rb' -exec sed -i -e 's:\r$::' {} +
+
+ # We can't use RUBY_PATCHES for this because we need first to convert the files
+ eapply "${FILESDIR}"/${P}+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/*_test.rb
+}