summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-07-12 07:56:48 +0200
committerHans de Graaff <graaff@gentoo.org>2024-07-12 07:59:01 +0200
commita5fa7f28843630ccf4380097b3346834ae22a3a5 (patch)
tree904410a35c3d2f9747a000e7ec0e60a0039f5460 /dev-ruby/path_expander
parentdev-ruby/neovim-ruby-client: add 0.10.0 (diff)
downloadgentoo-a5fa7f28843630ccf4380097b3346834ae22a3a5.tar.gz
gentoo-a5fa7f28843630ccf4380097b3346834ae22a3a5.tar.bz2
gentoo-a5fa7f28843630ccf4380097b3346834ae22a3a5.zip
dev-ruby/path_expander: add 1.1.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/path_expander')
-rw-r--r--dev-ruby/path_expander/Manifest1
-rw-r--r--dev-ruby/path_expander/path_expander-1.1.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/path_expander/Manifest b/dev-ruby/path_expander/Manifest
index ae36185b00fc..7f53854657f0 100644
--- a/dev-ruby/path_expander/Manifest
+++ b/dev-ruby/path_expander/Manifest
@@ -1 +1,2 @@
DIST path_expander-1.1.1.gem 13312 BLAKE2B d22b7253be821f7bf73bef48843b64356e5a4c66fb532844e4de25e9f4e01486560defda00d8cbc698a3d3b936cff742bdd3005afb32f9a41318d380d2f575cc SHA512 bd670b45bf8a265faf0ab9e845782e7bb6fa62e4360d3b5109b83b27afc54d3d372db1d0df9a098eb6935d24d29a973848c7b914b5ee0d67069ddc88c0aa79b7
+DIST path_expander-1.1.2.gem 13824 BLAKE2B 0f618b136b0322c8fcde8c2acbcc594108aaef4765d336f26ab8fa5bdd433d1577795f8a946987370fed4da5d7219d6b1115c930fd0a87a06d11579bd24420b8 SHA512 998aa55fa1cc31498ef65753aab734650031ae1e42a7f2b5757edd50ea57076f87ee6d5a03bc62d93768709f06dd0a0564080d8563dec0f9d7605501348dd718
diff --git a/dev-ruby/path_expander/path_expander-1.1.2.ebuild b/dev-ruby/path_expander/path_expander-1.1.2.ebuild
new file mode 100644
index 000000000000..42eac7956233
--- /dev/null
+++ b/dev-ruby/path_expander/path_expander-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pre-process CLI arguments expanding directories into their constituent files"
+HOMEPAGE="https://github.com/seattlerb/path_expander"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ # Fix tests depending on sort order
+ sed -i -e '/test_process_args_dir/,/^ end/ s:^:#:' \
+ -e '33 s/$/.sort/' \
+ -e '83 s/act/act.sort/' \
+ test/test_path_expander.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}