summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rake-remote_task
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rake-remote_task')
-rw-r--r--dev-ruby/rake-remote_task/Manifest3
-rw-r--r--dev-ruby/rake-remote_task/metadata.xml5
-rw-r--r--dev-ruby/rake-remote_task/rake-remote_task-2.2.1-r1.ebuild27
-rw-r--r--dev-ruby/rake-remote_task/rake-remote_task-2.2.2.ebuild28
-rw-r--r--dev-ruby/rake-remote_task/rake-remote_task-2.3.0.ebuild28
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-ruby/rake-remote_task/Manifest b/dev-ruby/rake-remote_task/Manifest
new file mode 100644
index 000000000000..2dc5306ba903
--- /dev/null
+++ b/dev-ruby/rake-remote_task/Manifest
@@ -0,0 +1,3 @@
+DIST rake-remote_task-2.2.1.gem 16896 SHA256 26e7f076540a8f1fc7f2dd3796753dfa958e40b26b05ba5532a3aad1fbeb3d95 SHA512 b01b6b393a0d2887b664b9567945d74766e5f5fb790d66960c66436a08c26b3ec739a0fe35317592f7c63cfc2aec687b69eca52fc52ec4151c62724044b43468 WHIRLPOOL e8915bc0896437d403b5941e22831c3f311330838cef806e7e4d2858eb29d9720582af9cf327d7de2d49c0340d6e33216daf286c0723d46c2130fee69f002ad5
+DIST rake-remote_task-2.2.2.gem 18944 SHA256 ca01188a5e9a94cc3cf9c5c8c455508ae3ac059aafe98c53427ef3f5e3c74043 SHA512 f26bdd63686587b111983fbb6d1a7e449785ea25b8c7facda71fa686fd091a021a1a75b2341163e73f215b5897ea64c355ffaed312d3db74308afe890a334eae WHIRLPOOL 043df936695763a1eeb0546225415491db74ef68a4c2924404c41ef2bdee89ce91a5a560dd69c2da50ca80a9ef35a976a8a4c10591756c29e75324041463617f
+DIST rake-remote_task-2.3.0.gem 18944 SHA256 7b70ae6293ed38ffa7794f7dfeebd54c039f69a691263a3cd2f6412ff7e7af26 SHA512 345c5e3f9a0f3eddc989733594a85fc7a5c6e31cb5288588854aa5866508529611c4e9cf2523ddb20ef4661c71243b5b72d199b7603d34fba851aa9544860949 WHIRLPOOL 41df09af7ccecc8fe353284c9eeaf32e1376dbd54a4c73bfc2d4974007956eebd977931802ae4cd5765e9d0893950b32a0b4d25e1bce594ea0a74de6640cff97
diff --git a/dev-ruby/rake-remote_task/metadata.xml b/dev-ruby/rake-remote_task/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/rake-remote_task/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rake-remote_task/rake-remote_task-2.2.1-r1.ebuild b/dev-ruby/rake-remote_task/rake-remote_task-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..668a8414dd16
--- /dev/null
+++ b/dev-ruby/rake-remote_task/rake-remote_task-2.2.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vlad the Deployer's sexy brainchild is rake-remote_task, extending Rake with remote task goodness"
+HOMEPAGE="http://rubyhitsquad.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/open4-1.0"
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/rake-remote_task/rake-remote_task-2.2.2.ebuild b/dev-ruby/rake-remote_task/rake-remote_task-2.2.2.ebuild
new file mode 100644
index 000000000000..4c924d6a264e
--- /dev/null
+++ b/dev-ruby/rake-remote_task/rake-remote_task-2.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vlad the Deployer's sexy brainchild is rake-remote_task, extending Rake with remote task goodness"
+HOMEPAGE="http://rubyhitsquad.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2
+ test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/open4-1.0"
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/rake-remote_task/rake-remote_task-2.3.0.ebuild b/dev-ruby/rake-remote_task/rake-remote_task-2.3.0.ebuild
new file mode 100644
index 000000000000..4c924d6a264e
--- /dev/null
+++ b/dev-ruby/rake-remote_task/rake-remote_task-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vlad the Deployer's sexy brainchild is rake-remote_task, extending Rake with remote task goodness"
+HOMEPAGE="http://rubyhitsquad.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2
+ test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/open4-1.0"
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}