summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-15 07:09:18 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-15 07:09:18 +0200
commiteb5cb132e8595e698959100b9a68708b3e366d43 (patch)
treeea77a7c9019ed3e0d5a5addf0f0d43115197c0e0 /dev-ruby/rjb
parentdev-ruby/pkg-config: add 1.4.3 (diff)
downloadgentoo-eb5cb132e8595e698959100b9a68708b3e366d43.tar.gz
gentoo-eb5cb132e8595e698959100b9a68708b3e366d43.tar.bz2
gentoo-eb5cb132e8595e698959100b9a68708b3e366d43.zip
dev-ruby/rjb: add 1.6.2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/Manifest1
-rw-r--r--dev-ruby/rjb/rjb-1.6.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
index 3ebcdc99db8d..b051a2c5e974 100644
--- a/dev-ruby/rjb/Manifest
+++ b/dev-ruby/rjb/Manifest
@@ -1 +1,2 @@
DIST rjb-1.6.1.gem 74240 BLAKE2B 103e3885634be9c7dd842c2737c420511fea04e4e2d18f77dba7689c47da996fa37af5d08827de21ec38effd3fd99407e99491c8b99d134dded219ccf3880b79 SHA512 5b78fc4eabceddeb901145af39b1fc76e9a44801596ea4bacf9ce601cc109107cf042b1aa4c27049abd766ffca3206364079866ce7b88d25657fa75e7593adc3
+DIST rjb-1.6.2.gem 74752 BLAKE2B 5b5c61933da5603c805d68c6a2514d193efb87f8a1ffdd38193152463338d963de09848d6d3ea027338c045d24b9e884c7befbaed75b288bfba7573fa4b1f10d SHA512 3147d606698d5dd99798fec71d60e09cf964dd9649d4cba6c2bab40055ecb2b129d39beba67063745ad884bf3ad1eda9c1e91350f52f6767b20d612b5b279642
diff --git a/dev-ruby/rjb/rjb-1.6.2.ebuild b/dev-ruby/rjb/rjb-1.6.2.ebuild
new file mode 100644
index 000000000000..564fb048d402
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.6.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="https://github.com/arton/rjb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+
+ # Fix build on openjdk-11
+ sed -i -e 's#javah -classpath ../data/rjb jp.co.infoseek.hp.arton.rjb.RBridge#javac -h . -classpath ../data/rjb RBridge.java#g' ext/extconf.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ if use examples; then
+ dodoc -r samples
+ fi
+}
+
+each_ruby_test() {
+ if use hardened; then
+ paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
+ if [ $? = 0 ]; then
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ else
+ ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
+ fi
+ else
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ fi
+}