summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-11-14 07:47:09 +0100
committerHans de Graaff <graaff@gentoo.org>2020-11-14 07:47:09 +0100
commit6c0c067bf2ea03633a46d31ec291aa99c26dc680 (patch)
tree540cea8567f9e521806152072c456cbc219e1145 /dev-ruby/rspec/rspec-3.10.0.ebuild
parentdev-ruby/rspec-core: add 3.10.0 (diff)
downloadgentoo-6c0c067bf2ea03633a46d31ec291aa99c26dc680.tar.gz
gentoo-6c0c067bf2ea03633a46d31ec291aa99c26dc680.tar.bz2
gentoo-6c0c067bf2ea03633a46d31ec291aa99c26dc680.zip
dev-ruby/rspec: add 3.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec/rspec-3.10.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-3.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-3.10.0.ebuild b/dev-ruby/rspec/rspec-3.10.0.ebuild
new file mode 100644
index 000000000000..517190c916cf
--- /dev/null
+++ b/dev-ruby/rspec/rspec-3.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"