summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-14 08:39:20 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-14 09:10:15 +0100
commit3198758179ac64bb35e0e8258e72dbc24188ed91 (patch)
tree564e4db6bd80d45d9662cf96294bb4b3891172ee /dev-ruby/tty-platform
parentdev-ruby/slow_enumerator_tools: add ruby30 (diff)
downloadgentoo-3198758179ac64bb35e0e8258e72dbc24188ed91.tar.gz
gentoo-3198758179ac64bb35e0e8258e72dbc24188ed91.tar.bz2
gentoo-3198758179ac64bb35e0e8258e72dbc24188ed91.zip
dev-ruby/tty-platform: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-platform')
-rw-r--r--dev-ruby/tty-platform/tty-platform-0.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/tty-platform/tty-platform-0.3.0-r1.ebuild b/dev-ruby/tty-platform/tty-platform-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..7851c83c23dc
--- /dev/null
+++ b/dev-ruby/tty-platform/tty-platform-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-platform.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Query methods for detecting different operating systems"
+HOMEPAGE="https://github.com/piotrmurach/tty-platform"
+SRC_URI="https://github.com/piotrmurach/tty-platform/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}