summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-26 11:29:23 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-26 11:29:31 +0200
commit39332659b3b8bf082b527dc67d32a1faf1753bb9 (patch)
treec9cc285b5cecacfc08e8039395bbd2bf2a1883e6 /dev-ruby
parenttexlive-common.eclass: fix iteration options (diff)
downloadgentoo-39332659b3b8bf082b527dc67d32a1faf1753bb9.tar.gz
gentoo-39332659b3b8bf082b527dc67d32a1faf1753bb9.tar.bz2
gentoo-39332659b3b8bf082b527dc67d32a1faf1753bb9.zip
dev-ruby/rubyzip: fix test on big-endian systems
Use the proper endian representation on all arches. Closes: https://bugs.gentoo.org/729632 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.3.0.ebuild3
-rw-r--r--dev-ruby/rubyzip/rubyzip-2.3.0.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild b/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
index cc2a60650cc9..5193e0b87464 100644
--- a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
+++ b/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
@@ -46,4 +46,7 @@ all_ruby_prepare() {
# Add missing requires
sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
+
+ # Fix broken test that uses native endian
+ sed -i -e '/pack/ s/LLS/VVv/' test/file_extract_test.rb || die
}
diff --git a/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild b/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild
index 16bec97ba963..f7274c64078d 100644
--- a/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild
+++ b/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild
@@ -48,4 +48,7 @@ all_ruby_prepare() {
# Add missing requires
sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
+
+ # Fix broken test that uses native endian
+ sed -i -e '/pack/ s/LLS/VVv/' test/file_extract_test.rb || die
}