summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-12 08:32:21 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-12 08:35:41 +0100
commit4f9ad88829913d5118fac387a631009134a39227 (patch)
treef0435a6878589b284d023afdb9142cb1b26cb3fa /dev-ruby
parentdev-ruby/rake-remote_task: cleanup (diff)
downloadgentoo-4f9ad88829913d5118fac387a631009134a39227.tar.gz
gentoo-4f9ad88829913d5118fac387a631009134a39227.tar.bz2
gentoo-4f9ad88829913d5118fac387a631009134a39227.zip
dev-ruby/rdoc: cleanup
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild b/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild
deleted file mode 100644
index b80b193bf8b3..000000000000
--- a/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
-HOMEPAGE="https://github.com/rdoc/rdoc/"
-
-LICENSE="Ruby MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- dev-ruby/racc
- test? (
- virtual/ruby-minitest
- )"
-
-ruby_add_rdepend "=dev-ruby/json-1* >=dev-ruby/json-1.4"
-
-# This ebuild replaces rdoc in ruby-1.9.2 and later.
-# ruby 1.8.6 is no longer supported.
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? (
- >=dev-lang/ruby-1.9.2:1.9
- )"
-
-all_ruby_prepare() {
- # Other packages also have use for a nonexistent directory, bug 321059
- sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/test_rdoc*.rb || die
-
- # Remove unavailable and unneeded isolate plugin for Hoe
- sed -i -e '/isolate/d' Rakefile || die
-
- # Remove licenses line from Hoe definitions so we also use older versions.
- sed -i -e '/licenses/ s:^:#:' Rakefile || die
-
- epatch "${FILESDIR}/${PN}-3.0.1-bin-require.patch"
-
- # Remove test that is depending on the locale, which we can't garantuee.
- sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
-
- # Remove test depending on FEATURES=userpriv, bug 361959
- sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
-
- # Avoid the generate rule since it doesn't work on jruby, see below.
- sed -i -e '/:generate/d' Rakefile || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- ruby -Ilib -S bin/rdoc || die
- fi
-}
-
-each_ruby_compile() {
- # Generate the file inline here since the Rakefile confuses jruby
- # into a circular dependency.
- for file in lib/rdoc/rd/block_parser lib/rdoc/rd/inline_parser ; do
- ${RUBY} -S racc -l -o ${file}.rb ${file}.ry || die
- done
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb test/test_*.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for bin in rdoc ri; do
- ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
-
- for version in 19 20; do
- if use ruby_targets_ruby${version}; then
- ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
- sed -i -e "1s/env ruby/ruby${version}/" \
- "${ED}/usr/bin/${bin}${version}" || die
- fi
- done
- done
-}