summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-07 08:28:41 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-07 08:28:41 +0200
commit74743cc9cfce817e7817e6fa56f54157b07be650 (patch)
tree36beb9e05dc79719116987f0fb9722e19b31c092 /dev-ruby
parentdev-ruby/asciidoctor: drop 2.0.18 (diff)
downloadgentoo-74743cc9cfce817e7817e6fa56f54157b07be650.tar.gz
gentoo-74743cc9cfce817e7817e6fa56f54157b07be650.tar.bz2
gentoo-74743cc9cfce817e7817e6fa56f54157b07be650.zip
dev-ruby/sshkit: add 1.23.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sshkit/Manifest1
-rw-r--r--dev-ruby/sshkit/sshkit-1.23.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 1df15670c2ab..bfa2552b79ae 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1,2 +1,3 @@
DIST sshkit-1.22.2.gem 146944 BLAKE2B 1059014a0537faa1ee0b19427b6654b8a8fa80a437c311f66d671dce029898f71e4f8aca7e68bb29144a3bd547ae747ab7862150ba53b9bdf29c273ee24ac79e SHA512 a01106d301e4bb8f372af4226d8b244a4da1aa1292c4f0eb0525543d49b05290af92efc3e0736b317b4f1a72d83802d7769a6322147128c03d7d8123cd25ff45
DIST sshkit-1.23.0.gem 146944 BLAKE2B a2015b0f2b5a5adc905bf89a0e1242abb2856646383a259ab85761014e5b908329f651f51a14bfa1c0356c8d861edf1239a0cf1e8fdb64819cd5a15f218552b0 SHA512 595900c195cfa247c89cbd0486c53aea3991db5ba7636cc778687ec31be58ee3120ef54b0682367625d3546199253a7d4ffca07bc7691f5dde3d4ae6a6e7f19c
+DIST sshkit-1.23.1.gem 146944 BLAKE2B 497b73da2ec4007e7264336536f7bea62c8ddf7e64d9779f0d2aa6d0b5471cdb155a130665931a3004131a6127c022b88d08613a321aedde124e057b1bb59bc7 SHA512 fb3d6e1de1fa68865421f299d7184d05918ef6d5c183fe21102ca277ffb70b8ecbf383f9b4489a39697c9adc5998c0b4c05483d9b08774c4b4201bd505b1488d
diff --git a/dev-ruby/sshkit/sshkit-1.23.1.ebuild b/dev-ruby/sshkit/sshkit-1.23.1.ebuild
new file mode 100644
index 000000000000..635a0f488c4c
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.23.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+# There are functional tests that require docker containers to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/base64
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+ >=dev-ruby/net-sftp-2.1.2
+ dev-ruby/ostruct
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -e '/\(unindent\|reporters\)/I s:^:#:' \
+ -e '/docker/I s:^:#:' \
+ -e '1irequire "pathname"' \
+ -i test/helper.rb || die
+ rm -f test/support/docker_wrapper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}