summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-11-02 17:50:55 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-11-02 17:50:55 +0100
commitb139508e420a131849e0953d10b1667fc3f3887a (patch)
treebde9e6373b0f3fd53ef575433f7cf327d449348b /dev-tcltk/thread/thread-2.8.2.ebuild
parentnet-analyzer/fail2ban: Version 0.10.4 (diff)
downloadgentoo-b139508e420a131849e0953d10b1667fc3f3887a.tar.gz
gentoo-b139508e420a131849e0953d10b1667fc3f3887a.tar.bz2
gentoo-b139508e420a131849e0953d10b1667fc3f3887a.zip
dev-tcltk/thread: Version bump to 2.8.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-tcltk/thread/thread-2.8.2.ebuild')
-rw-r--r--dev-tcltk/thread/thread-2.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-tcltk/thread/thread-2.8.2.ebuild b/dev-tcltk/thread/thread-2.8.2.ebuild
new file mode 100644
index 000000000000..700cd2a92305
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/project/tcl/Thread%20Extension/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/tcl:0=[threads]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}${PV}
+
+src_prepare() {
+ default
+
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-tclinclude="${EPREFIX}/usr/include" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}