summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-17 13:39:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-11 14:45:34 +0200
commit2e5642e8592dc15bac5a63f10c7a4e3008c9e150 (patch)
tree86c27a20706bebb9f00f98cb63a0b9776c593d31 /dev-tcltk
parentsci-geosciences/qgis: add missing rdep sci-libs/gdal[spatialite,sqlite], add ... (diff)
downloadgentoo-2e5642e8592dc15bac5a63f10c7a4e3008c9e150.tar.gz
gentoo-2e5642e8592dc15bac5a63f10c7a4e3008c9e150.tar.bz2
gentoo-2e5642e8592dc15bac5a63f10c7a4e3008c9e150.zip
dev-tcltk/tktreectrl: EAPI8 bump, use https
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Bug: https://bugs.gentoo.org/828839 Closes: https://bugs.gentoo.org/906870 Closes: https://github.com/gentoo/gentoo/pull/35391 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tktreectrl/tktreectrl-2.4.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/tktreectrl/tktreectrl-2.4.1-r1.ebuild b/dev-tcltk/tktreectrl/tktreectrl-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..f1c695b3fdd4
--- /dev/null
+++ b/dev-tcltk/tktreectrl/tktreectrl-2.4.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit virtualx
+
+DESCRIPTION="Flexible listbox widget for Tk"
+HOMEPAGE="https://tktreectrl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug shellicon threads"
+
+RDEPEND=">=dev-lang/tk-8.4:0="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/2.2.9-as-needed.patch )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ $(use_enable shellicon)
+ $(use_enable amd64 64bit)
+ $(use_enable debug symbols)
+ --with-x
+ --enable-shared
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_test() {
+ virtx emake test
+}
+
+src_install() {
+ default
+ mv \
+ "${ED}"/usr/lib*/treectrl${PV}/htmldoc \
+ "${ED}"/usr/share/doc/${PF}/ || die
+}