summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/abntex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/abntex')
-rw-r--r--dev-tex/abntex/Manifest2
-rw-r--r--dev-tex/abntex/abntex-0.9_beta2.ebuild60
-rw-r--r--dev-tex/abntex/metadata.xml15
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-tex/abntex/Manifest b/dev-tex/abntex/Manifest
new file mode 100644
index 000000000000..aaade5362885
--- /dev/null
+++ b/dev-tex/abntex/Manifest
@@ -0,0 +1,2 @@
+DIST abntex-0.9-beta2.tar.gz 159150 SHA256 6e94a0328f65494406c02e410725c1c9761468443c21accf0ece5ee77fcd4e62 SHA512 00027c5a7a60b15f9e1bf2cb782d6bdf106fbbff33b1c0be13f6404de9e3c81957a27d7c843b209a1f3b4660eb43236ff601034741cd560e6d88274f04a4edb8 WHIRLPOOL ac08d261e8a1beb18a9aafd67ce39cfc406063d88915a60b682fb1bf38f5089abee4a43c2d4cc8cd5da065dee8a3f6d739df4440fd7779786d20212026429de0
+DIST abntex-doc-0.9-beta2.tar.gz 1350153 SHA256 18cef1e4dc70c61b93bbf82004d990b0957ab081986d32d67bc15713be79f5c6 SHA512 2084e4d3a613140ab53dab2c782e0b7e07294bf60615d79ac7b0a75fd6ae350f365401fb5722266c1e540ab8a94671299cabcd007f799be01c520f39d1af6878 WHIRLPOOL 5d5168e9076af1dc795467678efd557a1d05bde3a27f138c9932f980fa53348c8b015f11590b7586318bce6b0b84ec3500cf8666a8fc0249bb7d6c158ab58b6c
diff --git a/dev-tex/abntex/abntex-0.9_beta2.ebuild b/dev-tex/abntex/abntex-0.9_beta2.ebuild
new file mode 100644
index 000000000000..5022b63ea955
--- /dev/null
+++ b/dev-tex/abntex/abntex-0.9_beta2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit latex-package
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="LaTeX macros for writing documents following the ABNT norms"
+HOMEPAGE="http://abntex.codigolivre.org.br/ http://abntex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-doc-${MY_PV}.tar.gz )"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples lyx"
+
+DEPEND="dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ lyx? ( app-office/lyx )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P%-*}"
+
+src_prepare() {
+ # fix permissions
+ find . -type f -exec chmod 0644 "{}" + || die 'chmod 0644 failed.'
+ find . -type d -exec chmod 0755 "{}" + || die 'chmod 0755 failed.'
+}
+
+src_install() {
+ dobin bin/geratss || die 'dobin failed.'
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r texmf/doc/* || die 'could not install examples.'
+ fi
+
+ rm -rf texmf/doc
+
+ insinto /usr/share/texmf-site
+ doins -r texmf/* || die 'could not install texmf.'
+
+ if use lyx; then
+ insinto /usr/share/lyx
+ doins -r lyx/* || die 'could not install lyx files.'
+ fi
+
+ dodoc LEIAME || die 'could not install LEIAME'
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/docs
+ doins -r compiled.docs/* || die "could not install doc"
+ fi
+}
diff --git a/dev-tex/abntex/metadata.xml b/dev-tex/abntex/metadata.xml
new file mode 100644
index 000000000000..dace8a819807
--- /dev/null
+++ b/dev-tex/abntex/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <use>
+ <flag name="lyx">Install with <pkg>app-office/lyx</pkg> layout</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">abntex</remote-id>
+ </upstream>
+</pkgmetadata>