summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-08 19:18:55 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-08 19:31:56 +0200
commit1ee72c67e1401471e40fcacd44a3ab4eb63d8c16 (patch)
treeb54a6af15e518b6f2a5eb90cd12cf288194cd3bd /dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild
parentdev-tex/catdvi: Bump EAPI to 7. (diff)
downloadgentoo-1ee72c67e1401471e40fcacd44a3ab4eb63d8c16.tar.gz
gentoo-1ee72c67e1401471e40fcacd44a3ab4eb63d8c16.tar.bz2
gentoo-1ee72c67e1401471e40fcacd44a3ab4eb63d8c16.zip
dev-tex/hyphen_show: Bump EAPI to 7.
Specify LICENSE more precisely. Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild')
-rw-r--r--dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild b/dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild
new file mode 100644
index 000000000000..e465b83c2d43
--- /dev/null
+++ b/dev-tex/hyphen_show/hyphen_show-20000425-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=${PN//_/-}
+DESCRIPTION="Show hyphenations in DVI files"
+HOMEPAGE="https://packages.debian.org/stable/tex/hyphen-show"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+PATCHES=("${FILESDIR}"/${PN}-gcc34.patch)
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} hyphen_show.c -o hyphen_show || die
+}
+
+src_install() {
+ dobin hyphen_show
+ doman hyphen_show.1
+ dodoc README.hyphen_show
+}