summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-01 10:58:53 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-01 11:05:34 +0100
commit50e314bed1fdc9d54fb463439d749de2269ae56d (patch)
tree8c6dce92ee2f91d6f00386ac0dbba5798db4aaaa /dev-tex/pgf
parentdev-tex/bibtexu: add 4.00_p20230311 (diff)
downloadgentoo-50e314bed1fdc9d54fb463439d749de2269ae56d.tar.gz
gentoo-50e314bed1fdc9d54fb463439d749de2269ae56d.tar.bz2
gentoo-50e314bed1fdc9d54fb463439d749de2269ae56d.zip
dev-tex/pgf: add 3.1.10
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-tex/pgf')
-rw-r--r--dev-tex/pgf/Manifest2
-rw-r--r--dev-tex/pgf/pgf-3.1.10.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-tex/pgf/Manifest b/dev-tex/pgf/Manifest
index 036c8017d172..3a7e6e3e326a 100644
--- a/dev-tex/pgf/Manifest
+++ b/dev-tex/pgf/Manifest
@@ -1,3 +1,5 @@
+DIST pgf-3.1.10-pgfmanual.pdf 10174139 BLAKE2B 038e00427575b02ace3310379a40e9d5b7362cea7d451bc3c9d5198f321d60e13acd1c0cf9a40ca0400c79a80f6c8b5b9eb98279ddb21e045c34d05c3ec7a261 SHA512 862291baddce938d735171c6b1c42b3acf9177a3009b3b7cfdf7188c399b5cb05e371650dc2214f1888875a497178ed18c0537f2c4628f3d6f563e8264cc43e0
+DIST pgf-3.1.10.tar.gz 2477289 BLAKE2B b43850eaa3b1d75d90b71f838579904fca5d0d9a6434350fef62a20dc7de6206c52c06dc70baf293165d6f89f22e28dfca9b22ba635a82994942b69b5b2161c4 SHA512 16c2cbcdcfa3a34d018a4436ef9e4944d2ac575c2b35403e87e7057837cdc7e95de576a1ea2cc37f5bdf77b87b0119f6e76969ceb910c2b1b97e3d6bb6a8cdf9
DIST pgf-3.1.9a-pgfmanual.pdf 10185873 BLAKE2B b4be2357eaa99d9db140172ae760acd157d02ae2def6d1cc3032ed998190231b67b5f8d80035feb54bf6552d4c4b14b2ba1247506feb0ce8334a43faab599d6f SHA512 84d90419f9fb4444765c5c76d42d74529ba3f716aadf99a723dc9c55c65511f1de6d8a56fff2d26dba3d3e6b26821e33da55c19e571a2130e5f389c4d3c88747
DIST pgf-3.1.9a-revisioned.xz 240 BLAKE2B 3a0c910e32c24635e65454468b20dcc49c9053bf786f0acb636171034a1b2a3fc2235a214f1fe2e2b0457baed09bb04d4425e6d3744ec50a6a44f2a8017f93af SHA512 be2c42c406c1887ad5e8af154d31fe779d2a3203b12785f67a2db8d3da7892f1793f9163dda2ce9ac1ac920a538a77e230464080796d15c4741169fdfc3df0cf
DIST pgf-3.1.9a.tar.gz 2693043 BLAKE2B 488c886f1ac8ba26a684321410018b94e7baf8a3a15e21d140318c0f553e76b34de9f1e6e85241b4a9f7cd314a0686f8045b99cbe50e71ba5db5abf020712e24 SHA512 db609a615487b2c4bf4efe46d5b6b1a20b7fd1fc313c6fb6493fe0f6d547a9f4f6b8c2edc1412af5a18faf38a8ec6c3d9642e6de473be34f5896280496e5f02c
diff --git a/dev-tex/pgf/pgf-3.1.10.ebuild b/dev-tex/pgf/pgf-3.1.10.ebuild
new file mode 100644
index 000000000000..c27820776254
--- /dev/null
+++ b/dev-tex/pgf/pgf-3.1.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit latex-package
+
+DESCRIPTION="The TeX Portable Graphic Format"
+HOMEPAGE="https://github.com/pgf-tikz/pgf"
+SRC_URI="
+ https://github.com/pgf-tikz/pgf/archive/${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/pgf-tikz/pgf/releases/download/${PV}/pgfmanual-${PV}.pdf -> ${P}-pgfmanual.pdf )
+"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended"
+
+src_install() {
+ einstalldocs
+
+ insinto "${TEXMF}"
+ doins -r tex
+ insinto "${TEXMF}"/tex/generic/${PN}
+ # Here is one of the rare examples where you want to quote the label
+ # of the heredoc to prevent the backticks from being evaluated.
+ newins - pgf.revision.tex <<"EOF"
+\begingroup
+\catcode`\-=12
+\catcode`\/=12
+\catcode`\.=12
+\catcode`\:=12
+\catcode`\+=12
+\catcode`\-=12
+\gdef\pgfrevision{@PVR@}
+\gdef\pgfversion{@PVR@}
+\gdef\pgfversiondatetime{2024-02-09 00:00:00 +0000}
+\gdef\pgfrevisiondatetime{2024-02-09 00:00:00 +0000}
+\gdef\pgf@glob@TMPa#1-#2-#3 #4\relax{#1/#2/#3}
+\xdef\pgfversiondate{\expandafter\pgf@glob@TMPa\pgfversiondatetime\relax}
+\xdef\pgfrevisiondate{\expandafter\pgf@glob@TMPa\pgfrevisiondatetime\relax}
+\endgroup
+EOF
+ sed -i s/@PVR@/${PVR}/ "${ED}/${TEXMF}"/tex/generic/${PN}/pgf.revision.tex || die
+
+ if use source ; then
+ doins -r source
+ fi
+
+ if use doc; then
+ cd "${S}/doc/generic/pgf" || die
+ docinto texdoc
+ # pgfmanual is now split from the main tar archive
+ newdoc "${DISTDIR}/${P}-pgfmanual.pdf" pgfmanual.pdf
+ doins -r images
+
+ dosym "../../../doc/${PF}/texdoc" "${TEXMF}/doc/latex/${PN}"
+ docompress -x "/usr/share/doc/${P}/texdoc/"
+ fi
+}