summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-13 00:07:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-13 00:22:03 +0100
commitac091635b574ccff9088320b86b38fbfcf18255e (patch)
treecee84b79481f3d8756c2dfd556ebcfeb2ca735db /dev-util/azuredatastudio
parentapp-office/joplin-desktop: bump to 2.13.13 (diff)
downloadgentoo-ac091635b574ccff9088320b86b38fbfcf18255e.tar.gz
gentoo-ac091635b574ccff9088320b86b38fbfcf18255e.tar.bz2
gentoo-ac091635b574ccff9088320b86b38fbfcf18255e.zip
dev-util/azuredatastudio: bump to 1.47.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-util/azuredatastudio')
-rw-r--r--dev-util/azuredatastudio/Manifest1
-rw-r--r--dev-util/azuredatastudio/azuredatastudio-1.47.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-util/azuredatastudio/Manifest b/dev-util/azuredatastudio/Manifest
index 98750f515155..85d5c8b38fed 100644
--- a/dev-util/azuredatastudio/Manifest
+++ b/dev-util/azuredatastudio/Manifest
@@ -1 +1,2 @@
DIST azuredatastudio-1.47.0-amd64.deb 138852252 BLAKE2B 20598aefb8ade4f1022213de1dfa17feddfb41ee0a241f8e9919e7573d00f3c3f81bbab947c9fec885a08b1e032a61616b1f49b943f3388c1edeb5502717e773 SHA512 7de1f1bafee735cfe7d52cb32324e38497ccb919a6322463b60bf2002af64546972f4ed207fdf0d9e55c48e33d7f5d7a9a3d10781c9c458edd4d18880ee5d310
+DIST azuredatastudio-1.47.1-amd64.deb 138850108 BLAKE2B f99374c00595f18f4a62e676235e1c5f71a47f14351ef3dc60c0bc84a69d15c325309be77613a4ba564e0f1322aed4fccc840ca871b83d0bbe2d48150e735afb SHA512 ad310cbb9955b8e46f8fdbcceb45ada6e61e2de8c0c40ff93312e7510f43fe675f1239ac07e095fee5573f034efc6fefbde13ebf70bae2f75e297a0e0e95df32
diff --git a/dev-util/azuredatastudio/azuredatastudio-1.47.1.ebuild b/dev-util/azuredatastudio/azuredatastudio-1.47.1.ebuild
new file mode 100644
index 000000000000..e59de53fa0ee
--- /dev/null
+++ b/dev-util/azuredatastudio/azuredatastudio-1.47.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="Data management and development tool from Microsoft"
+HOMEPAGE="https://learn.microsoft.com/sql/azure-data-studio/
+ https://github.com/microsoft/azuredatastudio/"
+SRC_URI="
+ amd64? (
+ https://azuredatastudio-update.azurewebsites.net/${PV}/linux-deb-x64/stable
+ -> ${P}-amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="kerberos"
+RESTRICT="bindist"
+
+# This is based on VSCode/VSCodium, so just copy their "RDEPEND".
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+DEPEND="
+ dev-libs/openssl-compat:1.0.0
+"
+BDEPEND="
+ dev-util/patchelf
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack_deb "${A}"
+}
+
+src_prepare() {
+ default
+
+ cd "${S}/usr/share" || die
+
+ mv appdata metainfo || die
+ mv zsh/vendor-completions zsh/site-functions || die
+
+ cd "${PN}" || die
+
+ # Kerberos libs, same issue as VSCode/VSCodium.
+ if ! use kerberos ; then
+ rm -r resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Patch "System.Security.Cryptography.Native.OpenSsl.so": *.so.10 -> *.so.1.0.0
+ local mssql_extension_version=4.10.2.1
+ local lib=System.Security.Cryptography.Native.OpenSsl.so
+ cd "resources/app/extensions/mssql/sqltoolsservice/Linux/${mssql_extension_version}" || die
+ patchelf --add-needed libcrypto.so.1.0.0 "${lib}" || die
+ patchelf --add-needed libssl.so.1.0.0 "${lib}" || die
+ patchelf --remove-needed libcrypto.so.10 "${lib}" || die
+ patchelf --remove-needed libssl.so.10 "${lib}" || die
+}
+
+src_install() {
+ cp -r . "${ED}" || die
+
+ dosym -r "/usr/share/${PN}/${PN}" "/usr/bin/${PN}"
+}