summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDouglas Agbeve <douglas@agbeve.com>2021-12-19 20:21:02 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 20:18:38 -0800
commit3aadc88d1b942fdfe737a2f83d26a4861dd1b4ed (patch)
tree294ab5e14a00508a9aef713020cf2829d98df327 /dev-util/bear
parentdev-perl/libwww-perl: fix MismatchedPerlVersion for 6.580.0 (diff)
downloadgentoo-3aadc88d1b942fdfe737a2f83d26a4861dd1b4ed.tar.gz
gentoo-3aadc88d1b942fdfe737a2f83d26a4861dd1b4ed.tar.bz2
gentoo-3aadc88d1b942fdfe737a2f83d26a4861dd1b4ed.zip
dev-util/bear: bump to v3.0.17
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Douglas Agbeve <douglas@agbeve.com> Closes: https://github.com/gentoo/gentoo/pull/23423 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/bear')
-rw-r--r--dev-util/bear/Manifest1
-rw-r--r--dev-util/bear/bear-3.0.17.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index 250709be46ab..01fadb98ab4f 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1,2 +1,3 @@
DIST bear-2.4.4.tar.gz 50347 BLAKE2B 73fa332cf97413e55c588f8830806a26c6905299af902c6cf1f39fd576c6261690239c1b502b28b5a2aa24e5ca521c3f1dd58aacd60e00ece4fe1840f5656155 SHA512 4ee3fd5c846149029fe9e4104e2a0d0e318a15215aa80fc5dc376e22ebea510384b02d4d62765495343cab537bacd2b1b0130c00246e081feb4e543761a594e5
DIST bear-3.0.16.tar.gz 122948 BLAKE2B bb720170488968e79d26b7022859a3a55f191661a65d8c5c1ce6120911919ffcd74a32035eebb419e4fe9a616f6dec1c66804445d9e8b243c7d26a87284f7776 SHA512 3906011aa01f42c7841046614e9f1972a39288749cbdeab4b55e517d48a05cb02a48be2b055b4ce65300ffa0a940609e713f55bd1a47ce4fc9a8cb2702487f07
+DIST bear-3.0.17.tar.gz 123861 BLAKE2B 9dea85c7c0ec5ec4954d08147cdac31e0b28c9780281a544687340e6e226e5403ad82f74db0fb9edd3f65c9a982531afb612e1c744430735e6de97d8d29a2189 SHA512 08e50b04c87745ae60623c32de07e710ffb4e78d9978f13cca9d51929b45477c780f1fe47178569310dca20dab5fef49dbffdf17a087c388f111eb11ffadf5b1
diff --git a/dev-util/bear/bear-3.0.17.ebuild b/dev-util/bear/bear-3.0.17.ebuild
new file mode 100644
index 000000000000..94cca1494941
--- /dev/null
+++ b/dev-util/bear/bear-3.0.17.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Build EAR generates a compilation database for clang tooling"
+HOMEPAGE="https://github.com/rizsotto/Bear"
+SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-cpp/nlohmann_json-3.7:=
+ >=dev-db/sqlite-3.14:=
+ >=dev-libs/libfmt-6.2:=
+ dev-libs/protobuf:=
+ >=dev-libs/spdlog-1.5
+ >=net-libs/grpc-1.26:=
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-cpp/gtest-1.10
+ )
+"
+
+BDEPEND="test? (
+ $(python_gen_any_dep '
+ dev-python/lit[${PYTHON_USEDEP}]
+ ')
+)"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P^}"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ # Turn off testing before installation
+ sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_UNIT_TESTS="$(usex test ON OFF)"
+ -DENABLE_FUNC_TESTS="$(usex test ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if has sandbox ${FEATURES}; then
+ ewarn "\'FEATURES=sandbox\' detected"
+ ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
+ ewarn "Skipping tests"
+ elif
+ has usersandbox ${FEATURES}; then
+ ewarn "\'FEATURES=usersandbox\' detected"
+ ewarn "Skipping tests"
+ elif
+ has network-sandbox ${FEATURES}; then
+ ewarn "\'FEATURES=network-sandbox\' detected"
+ ewarn "Skipping tests"
+ elif
+ has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
+ ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
+ ewarn "and will fail without generic cc symlink"
+ ewarn "Skipping tests"
+ else
+ einfo "test may use optional tools if found: qmake gfortran valgrind"
+ # unit tests
+ cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
+ # functional tests
+ cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
+ fi
+}