summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2020-05-24 12:46:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-05 11:24:15 +0300
commit15477285327859b353e2a12c7943d869b5d740c0 (patch)
treeed16f44cf8527546a1e53255c9cb928f3a97ab7b /dev-util/bloaty
parentdev-util/bloaty: bump version to 1.1 (diff)
downloadgentoo-15477285327859b353e2a12c7943d869b5d740c0.tar.gz
gentoo-15477285327859b353e2a12c7943d869b5d740c0.tar.bz2
gentoo-15477285327859b353e2a12c7943d869b5d740c0.zip
dev-util/bloaty: add 9999 live ebuild
Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/15944 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/bloaty')
-rw-r--r--dev-util/bloaty/bloaty-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/bloaty/bloaty-9999.ebuild b/dev-util/bloaty/bloaty-9999.ebuild
new file mode 100644
index 000000000000..4aa412ab17d3
--- /dev/null
+++ b/dev-util/bloaty/bloaty-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A size profiler for binaries"
+HOMEPAGE="https://github.com/google/bloaty"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/${PN}"
+ IUSE="test"
+ RESTRICT="!test? ( test )"
+else
+ SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/capstone:=
+ dev-libs/protobuf:=
+ dev-libs/re2:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLOATY_ENABLE_CMAKETARGETS=OFF
+ )
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ fi
+ cmake_src_configure
+}