summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-03 22:30:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-03 22:30:25 +0200
commitb5d8c7d97590906dad75eefd771cd62e67a27a19 (patch)
treeadc9137a798b5546f750dfa5aa1b425d6d21edec /dev-util/checkbashisms/checkbashisms-2.18.2.ebuild
parentgames-action/bzflag: Version bump to 2.4.14 (diff)
downloadgentoo-b5d8c7d97590906dad75eefd771cd62e67a27a19.tar.gz
gentoo-b5d8c7d97590906dad75eefd771cd62e67a27a19.tar.bz2
gentoo-b5d8c7d97590906dad75eefd771cd62e67a27a19.zip
dev-util/checkbashisms: Bump to v2.18.2
No changes in checkbashisms. Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.18.2.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.18.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.18.2.ebuild b/dev-util/checkbashisms/checkbashisms-2.18.2.ebuild
new file mode 100644
index 000000000000..be58ae776f20
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.18.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ default
+
+ eapply -p2 "${FILESDIR}"/${PN}-2.15.9-command-vV.patch
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}