summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-31 13:53:21 +0100
committerJeroen Roovers <jer@gentoo.org>2017-10-31 15:05:50 +0100
commitd1a413ec48c6920d16ea9eaaaa9fc1f9c3bc5805 (patch)
treeb0b82a4cd6d99b77dbd8ccab15323657fcea54f1 /dev-util/debootstrap/debootstrap-1.0.92.ebuild
parentnet-analyzer/testssl: remove 2.8 (diff)
downloadgentoo-d1a413ec48c6920d16ea9eaaaa9fc1f9c3bc5805.tar.gz
gentoo-d1a413ec48c6920d16ea9eaaaa9fc1f9c3bc5805.tar.bz2
gentoo-d1a413ec48c6920d16ea9eaaaa9fc1f9c3bc5805.zip
dev-util/debootstrap: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-util/debootstrap/debootstrap-1.0.92.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.92.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-1.0.92.ebuild b/dev-util/debootstrap/debootstrap-1.0.92.ebuild
new file mode 100644
index 000000000000..fc955a4bad4e
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.92.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}