summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2024-11-10 15:05:10 -0500
committerEli Schwartz <eschwartz@gentoo.org>2024-11-29 16:12:18 -0500
commitc4de24131b5dd7d2fde65ef5bc1b99394d9438aa (patch)
tree78b6cd7580fcaf642f8ca45d7b04abbbf8fd64c5 /dev-util/diff-cover
parentapp-dicts/myspell-en: add 20241101 (diff)
downloadgentoo-c4de24131b5dd7d2fde65ef5bc1b99394d9438aa.tar.gz
gentoo-c4de24131b5dd7d2fde65ef5bc1b99394d9438aa.tar.bz2
gentoo-c4de24131b5dd7d2fde65ef5bc1b99394d9438aa.zip
dev-util/diff-cover: add 9.2.0
Fix testsuite Add python3_12, python3_13 Signed-off-by: Andrew Udvare <audvare@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39262 Closes: https://bugs.gentoo.org/929534 Closes: https://bugs.gentoo.org/788280 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-util/diff-cover')
-rw-r--r--dev-util/diff-cover/Manifest1
-rw-r--r--dev-util/diff-cover/diff-cover-9.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/diff-cover/Manifest b/dev-util/diff-cover/Manifest
index 90948e9f831a..72249c7ac402 100644
--- a/dev-util/diff-cover/Manifest
+++ b/dev-util/diff-cover/Manifest
@@ -1,2 +1,3 @@
DIST diff-cover-6.5.0-testfixtures.patch 18608 BLAKE2B d298ca1b756ef7fce4a449c4b84fd5508496f13006e11d93af791b20f47a8039e7a3d7ac2c400577f7816db14b4c84f6aacf361f3d3c57d02278d36f3cc40236 SHA512 3a3041edcbca00a336cbe5b3b8c4aa648a0b70bbcd190349968610d0dc6115da0e5e258fe14de6f73c975d9adf72955126ef9266fd16f82db6d1d683095c64b9
DIST diff-cover-6.5.0.tar.gz 108392 BLAKE2B fc3a2a46e66501da5c08ce58fc13e46671246737320a0b6350b78f6b777d3759ec47d4ada170bb3dffcfe0927920741a3c5bff03509d92b2cc873cecce282eb1 SHA512 a00a1009fc8b9ca46f93573e3a2d6eb6a6a29f0e61891c839209dbe3d208d873a42524b30e3a18918817d173cefc3c5f481f7eea689170d72b5cd08857a8f021
+DIST diff-cover-9.2.0.tar.gz 110215 BLAKE2B 7acc40be1464c4a5d0d95ed4f1d11e40302a0fc2aee751857154022a1e096afaaa656994c1c347c8cfdb6ec10684fe774d994a6a4e919a048997e18ce7f27310 SHA512 41289b4e4c37615155293df4058860b7118329784ed18afdf3624147f7d6ade6eedb86f17eb930c9f1f910c8723ee0ebafe074244cab7b3283e8135fa751ec00
diff --git a/dev-util/diff-cover/diff-cover-9.2.0.ebuild b/dev-util/diff-cover/diff-cover-9.2.0.ebuild
new file mode 100644
index 000000000000..1e45da02d90e
--- /dev/null
+++ b/dev-util/diff-cover/diff-cover-9.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Find diff lines that do not have test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/diff-cover/diff_cover}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.13.1[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.1[${PYTHON_USEDEP}]
+"
+# Note: flake8/pylint called as shell tools, not imported libraries
+BDEPEND="
+ test? (
+ dev-python/flake8
+ dev-python/pylint
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Remove project's flake8 config because it causes a test that calls `flake8 --version` to fail
+ rm .flake8 || die
+ distutils-r1_src_test
+}