summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-11-17 01:06:01 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-11-17 01:06:56 +0300
commit7cbec58a3a12c898ae15ebbe78e3fd81e8ceb894 (patch)
treec46dc529b9a1bfeea5635c98c196933544c7c03e /dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild
parentgames-misc/xcowsay: remove unused patch (diff)
downloadgentoo-7cbec58a3a12c898ae15ebbe78e3fd81e8ceb894.tar.gz
gentoo-7cbec58a3a12c898ae15ebbe78e3fd81e8ceb894.tar.bz2
gentoo-7cbec58a3a12c898ae15ebbe78e3fd81e8ceb894.zip
dev-util/dropwatch: version bump and fixes
- update to the latest git HEAD snapshot (20150706); - update to EAPI 6; - add subsolt dep on binutils-libs (fixes bug 599908), thanks Thomas Deutschmann (whissi@gentoo.org) for the report and the patch. Package-Manager: portage-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild')
-rw-r--r--dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild b/dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild
new file mode 100644
index 000000000000..69c033d45ddc
--- /dev/null
+++ b/dev-util/dropwatch/dropwatch-1.4_p20150706.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="A utility to interface to the kernel to monitor for dropped network packets"
+HOMEPAGE="https://fedorahosted.org/dropwatch/"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libnl:3
+ sys-libs/binutils-libs:=
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NET_DROP_MONITOR"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${PN}-1.4-binutils-2.23.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" -C src
+}
+
+src_install() {
+ dobin "src/${PN}"
+ doman "doc/${PN}.1"
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Ensure that 'drop_monitor' kernel module is loaded before running ${PN}"
+}