summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-11-19 08:52:16 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-11-19 08:52:16 -0500
commitb5e4991db94c8eda96aeff34218edd96d7f5553d (patch)
treec6fd5c09e481d18da505bff3bec009209aa5e384 /dev-util/elfkickers/elfkickers-3.1a.ebuild
parentnet-dns/unbound: bump to v1.9.5 (diff)
downloadgentoo-b5e4991db94c8eda96aeff34218edd96d7f5553d.tar.gz
gentoo-b5e4991db94c8eda96aeff34218edd96d7f5553d.tar.bz2
gentoo-b5e4991db94c8eda96aeff34218edd96d7f5553d.zip
dev-util/elfkickers: version bump to 3.1a
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-util/elfkickers/elfkickers-3.1a.ebuild')
-rw-r--r--dev-util/elfkickers/elfkickers-3.1a.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/elfkickers/elfkickers-3.1a.ebuild b/dev-util/elfkickers/elfkickers-3.1a.ebuild
new file mode 100644
index 000000000000..7faed18f930f
--- /dev/null
+++ b/dev-util/elfkickers/elfkickers-3.1a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=${PN/elf/ELF}-${PV}
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc"
+HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
+SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="app-misc/pax-utils"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1-respect-CFLAGS-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-3.1-create-destdir-path.patch
+ "${FILESDIR}"/add-freebsd-elf-defs.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s:^prefix = /usr/local:prefix = ${D}:" Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) all
+}