summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-24 10:24:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-24 10:25:09 -0500
commit8100d429872fb38c2518d92d6a83290a09dbb29b (patch)
tree11a2dd3de47997c11c1244fae34afda52f9e24dd /dev-util/gertty
parentnet-analyzer/nessus-agent-bin: add maintainer (diff)
downloadgentoo-8100d429872fb38c2518d92d6a83290a09dbb29b.tar.gz
gentoo-8100d429872fb38c2518d92d6a83290a09dbb29b.tar.bz2
gentoo-8100d429872fb38c2518d92d6a83290a09dbb29b.zip
dev-util/gertty: update to 1.6.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-util/gertty')
-rw-r--r--dev-util/gertty/Manifest1
-rw-r--r--dev-util/gertty/gertty-1.6.0.ebuild43
-rw-r--r--dev-util/gertty/gertty-9999.ebuild4
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-util/gertty/Manifest b/dev-util/gertty/Manifest
index 081b319d4efe..6867912d975d 100644
--- a/dev-util/gertty/Manifest
+++ b/dev-util/gertty/Manifest
@@ -1,3 +1,4 @@
DIST gertty-1.3.2.tar.gz 92553 BLAKE2B 2e6771fcf044a8a46e91dbc6f34869be528e0aa4db8344aa26a999bfb9fe1a8e7b18346f1d90f06b7cb436c74a2c04c5528297d126e66b8f985bfc42483c53cc SHA512 b68acb801ceb225fe86d62015fd89bce7ebe34219dbb2f7fe10d991ff06b558a5ed3512e6435ef3ce13324841c473dbec565c7bef23e01567f5bdcbb6aba9136
DIST gertty-1.4.0.tar.gz 115581 BLAKE2B af1a4ceac5b1e189305463e91d8d79246ccf16d5109b5100c0f928af42c39632d2c4b904c5586428c31d5d12985baf8ed2507c743364d6b26a4a02967b59dfc3 SHA512 9abba6271d3ec95938f07ab4ee76f0b539a7ce7f0bbf9c08509fe9516c14f99ccb7b439d29a30bff6dca99bf39788dc803cd8aed3cc03b531678225fa41102d9
DIST gertty-1.5.0.tar.gz 119784 BLAKE2B bc563c10009c372de5a702b4ab33d9b6b26a898486fc5a1d840f298b50a779c36467ccf6600b6f29b61d3c15b1cc0bbfe960d0d6a1a71d3f8b8f75dc392ab0dc SHA512 bc47817a3ba9ccce298ee1a646cb43f8a57e9a57a40d898859836b3171abd0cf3c682a5f5811cf3d987a17dbf00dd6706a5dbc5a6a35f1d5ff3a217c68187cda
+DIST gertty-1.6.0.tar.gz 122570 BLAKE2B 8c3628f9b0b56aaff30f183a1ab0d852b8ee487927833f41b8aa61f94f8d14eaf3a8d515d5edcb3fa7dd18ca36f42a977d12790c52d6c629a720b4f29252b030 SHA512 0fe5224f5b4b06910bba0d19453ea0f273f6ea0688b9aa092e11f929b71801581f6d7cead1d64c00912ee3363b98d4b36e903fa992a7ce36f190a4f3c09375d2
diff --git a/dev-util/gertty/gertty-1.6.0.ebuild b/dev-util/gertty/gertty-1.6.0.ebuild
new file mode 100644
index 000000000000..1987101fe4e3
--- /dev/null
+++ b/dev-util/gertty/gertty-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
+HOMEPAGE="https://pypi.org/project/gertty/"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/ttygroup/gertty"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/git-python-0.3.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
diff --git a/dev-util/gertty/gertty-9999.ebuild b/dev-util/gertty/gertty-9999.ebuild
index c59d3edabcd2..1987101fe4e3 100644
--- a/dev-util/gertty/gertty-9999.ebuild
+++ b/dev-util/gertty/gertty-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
inherit distutils-r1
@@ -35,7 +35,7 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
<dev-python/requests-3.0.0[${PYTHON_USEDEP}]
- dev-python/ordereddict[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' 'python2*')
>=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
>=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]