summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-05-18 17:51:49 -0400
committerMatt Turner <mattst88@gentoo.org>2024-05-22 12:49:31 -0400
commita8cbbe6b8f6df4990000594f5688fd207ba79d28 (patch)
tree997100c337e5fcc4e44827765d038b115ff868e0 /dev-util/git-fixup
parentdev-libs/xerces-c: Fix build w/ ICU-75 (diff)
downloadgentoo-a8cbbe6b8f6df4990000594f5688fd207ba79d28.tar.gz
gentoo-a8cbbe6b8f6df4990000594f5688fd207ba79d28.tar.bz2
gentoo-a8cbbe6b8f6df4990000594f5688fd207ba79d28.zip
dev-util/git-fixup: Add new package, version 1.6.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/git-fixup')
-rw-r--r--dev-util/git-fixup/Manifest1
-rw-r--r--dev-util/git-fixup/git-fixup-1.6.1.ebuild26
-rw-r--r--dev-util/git-fixup/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/git-fixup/Manifest b/dev-util/git-fixup/Manifest
new file mode 100644
index 000000000000..b815f8a8beea
--- /dev/null
+++ b/dev-util/git-fixup/Manifest
@@ -0,0 +1 @@
+DIST git-fixup-1.6.1.tar.gz 8571 BLAKE2B 4451f1af753d6bd13a5a9d11f79b313f8a2b00f2f386c89eb14e8d2af6cf9c1f424328912160d2059b173fc9f64271872a816b53de340413ef779ff6bcc21bfc SHA512 502d0a188333420ea2467bfc22bbfeefab595cc951777403baaafaa14b34c138adaee590fdc09ce71faf58d13666f85cdd8495a4039632c73d269565336c381f
diff --git a/dev-util/git-fixup/git-fixup-1.6.1.ebuild b/dev-util/git-fixup/git-fixup-1.6.1.ebuild
new file mode 100644
index 000000000000..8ea2e80d5334
--- /dev/null
+++ b/dev-util/git-fixup/git-fixup-1.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/keis/git-fixup"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/keis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Fighting the copy-paste element of your rebase workflow"
+HOMEPAGE="https://github.com/keis/git-fixup"
+
+LICENSE="ISC"
+SLOT="0"
+
+RDEPEND="!<app-portage/mgorny-dev-scripts-53"
+
+src_compile() { :; }
+
+src_install() {
+ emake install{,-fish,-zsh} DESTDIR="${ED}" PREFIX="${EPREFIX}/usr"
+}
diff --git a/dev-util/git-fixup/metadata.xml b/dev-util/git-fixup/metadata.xml
new file mode 100644
index 000000000000..a8aecbb07bf7
--- /dev/null
+++ b/dev-util/git-fixup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keis/git-fixup</remote-id>
+ </upstream>
+</pkgmetadata>