summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-11-16 15:47:51 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-11-16 15:48:14 -0600
commit39fdfb0d87c114f5faef9d0be7b0d4da48e52e86 (patch)
tree13dee63b0eb09a296582e5e8dcc555b44da40ca6 /dev-util/gitlab-runner
parentsci-libs/tokenizers: add 0.14.1, drop 0.14.0 (diff)
downloadgentoo-39fdfb0d87c114f5faef9d0be7b0d4da48e52e86.tar.gz
gentoo-39fdfb0d87c114f5faef9d0be7b0d4da48e52e86.tar.bz2
gentoo-39fdfb0d87c114f5faef9d0be7b0d4da48e52e86.zip
dev-util/gitlab-runner: add 16.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.6.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index c1088dcae267..f2e3c7c36060 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-16.4.2-deps.tar.xz 218831500 BLAKE2B e639c446aafd9095e07a6dd6
DIST gitlab-runner-16.4.2.tar.bz2 1371196 BLAKE2B 9ff9073fa69a4a04b59d9e3274eec9c86817fd198f3b3ab877352869eb5d5bb0f1aab69fd9500d9f87ac3ca4def9b6d286d82905be4e48014fa902f29dc9c6b5 SHA512 59817206b4d654ec27512fd0713d7d2a879ca4cd6e1abe46e0314c90db49795316f8b6d196f9b5bf11d9ff04efd16f8d580131a39ac20cc21ed4c3bc83e9d5b9
DIST gitlab-runner-16.5.0-deps.tar.xz 218830692 BLAKE2B 91f1b48239f8da19c93f5b9ec3ba30a1fceb0d17f72395dc85cbbd2a584845977044b920ea19b1d01df62f90cfc86cfcd354e0c3d49b7dba8e216f8cbeae057c SHA512 3d07800019ef800d5db79d7f8696c4fbfb3ffebbe4c9367e0af02d2abcf56e5d09f837b6fdb29e12eb5a04b9a48c00fc0a6e8e955b1fe91c6bc87d0e8c33f2d6
DIST gitlab-runner-16.5.0.tar.bz2 1373002 BLAKE2B 25ac77ffa71a633cad2b99211acf68595a3ee293f5af3e7cd813ec5a9b70a252413ed99d3b354ef713fb08b9dfeb140e7daa7a3cfd168d4af270034147657dac SHA512 59f03814a44d53c573b336f3eff9d1d273bc6b601e86cc58ca91778705a7897c999bd30e92361aa9294a91596505ca2950d56ad9cc64db7aa40a204ab4a4173d
+DIST gitlab-runner-16.6.0-deps.tar.xz 223036872 BLAKE2B 2ed2ec80bb6de33b2ba8ab002edb4f96da34ac2cdd52f289bb128b61c670335477f1cf46b384304b47b0972bb2d029fd5763385dc63b6b21fcc9148d905a7df0 SHA512 96fcd9555cb501daaaee114d0da2f2b5b83644f3c9154e31b2a6208ac4fd043a7457157da4b1ed0d287841ceaa4d9101f3a4d198804bcb7833b07db73a14ffd4
+DIST gitlab-runner-16.6.0.tar.bz2 1335612 BLAKE2B 431f8b393fdeec46eb8e7b61c8892c75be5c2183f9a04e1d3a078313e62e37863d9e59b7163e9cc2b6efdba79c719c4244ec64dbee997ea9e39b81fcaeda6794 SHA512 6dfbc0eb145752a7d1891aafdaf4641dafc263a97b4c4b37c2dad3bfc9a44db2aa4059f7f76ecf11280cf06c61a01648f41af22997ba79bcda57f241ef2686b1
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.6.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.6.0.ebuild
new file mode 100644
index 000000000000..7a4920e0ac49
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.6.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=3046fee8
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}