summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-11-09 08:24:55 -0600
committerWilliam Hubbs <williamh@gentoo.org>2018-11-09 08:25:49 -0600
commite34c5dd5981bc7b1a00de8786ae95ff185323a6f (patch)
tree1f353a44ee048be7a952378d81e27760c741aa26 /dev-util/meson
parentdev-python/bcrypt: eapi7 + py3_7 (diff)
downloadgentoo-e34c5dd5981bc7b1a00de8786ae95ff185323a6f.tar.gz
gentoo-e34c5dd5981bc7b1a00de8786ae95ff185323a6f.tar.bz2
gentoo-e34c5dd5981bc7b1a00de8786ae95ff185323a6f.zip
dev-util/meson: 0.48.2 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/meson')
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.48.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index c3e2245d4925..9f29af06de57 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -2,3 +2,4 @@ DIST meson-0.46.1.tar.gz 1203731 BLAKE2B 3b6b78e24a4d1ff3166db5546dda80e8b29236b
DIST meson-0.47.1.tar.gz 1250211 BLAKE2B a1ef5852b432e6856733c25a7ccd225f1a9ff2d1a8f65a38375d13c2c1d93d8e756b2cc2d3528783f18b90598e3f056363822d2400773369457d0801a6e3dd58 SHA512 e5042f0553057eb3a723fd2e17994ff05c2856c0dc22f39f5c5eb68fb56281894a5d13fe9f2e0852b4c934f3f3cbc41e0639ff25db4ab9f352eff95e7d552b8b
DIST meson-0.48.0.tar.gz 1307251 BLAKE2B cafae408a219a8f31b756cae28178480eeadac877a6a694c1369c7524b68b88e606d51823aacde177410fd97c1ad14793a11a6d1a1a97c131d33b1014ca2d5f9 SHA512 99ba4ca4899a3174803e41fe5a010d4be304cf85d7392107c2a6ad65f03d758382b1b9104a0cc54bf6fdba28e7742ecd2b0c299d43be3a66fb1381b77418036b
DIST meson-0.48.1.tar.gz 1310408 BLAKE2B e90c5c0b396883ac516eb3a5de04a1caff084a7f018e3f9b7565ec91e520bf4c0e05a72855b3b35e361623c6bf792e471846a7bac13fabd8b42c5256af017703 SHA512 248856cbab0aba959a01a9759261108baf93eef92d454b9ebb7f54edf1aa3e26f6050e389c9889ca23b19321d835617bacd361fc598b7185f6485bc6a403534c
+DIST meson-0.48.2.tar.gz 1311011 BLAKE2B 54cb8ca4164238f1c2b77327c330a7615a8d62c63c0cbedcdbe395bf2a99c454407fbc61af8d61d38a85de5dee18e73b98b534a2c9d19cc8f622e25549b84bbf SHA512 beebc90df420c15255c49a13e2f4917934fec8fb2c5b878a59ee0cd2ae46eb05571e995e12b3110b72be89fd11ab4c534ed72aa6d6fe72719ef060df5e75695f
diff --git a/dev-util/meson/meson-0.48.2.ebuild b/dev-util/meson/meson-0.48.2.ebuild
new file mode 100644
index 000000000000..d7d772117ac9
--- /dev/null
+++ b/dev-util/meson/meson-0.48.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ (
+ # test_meson_installed
+ unset PYTHONDONTWRITEBYTECODE
+
+ # test_cross_file_system_paths
+ unset XDG_DATA_HOME
+
+ ${EPYTHON} -u run_tests.py
+ ) || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles
+ doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
+ insinto /usr/share/zsh/site-functions
+ doins data/shell-completions/zsh/_meson
+}